
The Basics

This chapter discusses the basic layout of KeyCAD Pro for Windows and
Macintosh. The general layout of the Program Start Up Window is displayed
with all of the correct names of tools, menus, readouts, etc.  Each toolbox
found within the program is explained in a general overview of how those
particular tools work.

This chapter is not intended to provide a step by step explanation of each
toolbox and readout. To gain a more detailed explanation of how to use
specific tools, menus or commands, refer to the appropriate chapter in this
manual.
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Edit Toolbox

The Edit Toolbox contains tools that are used on previously designed
objects.  There are only two tools within the Edit toolbox that do not edit
the shape of predrawn objects.  These are the Zoom tool and the Text tool.

Remember that the following tools require that an object or points within
an object be selected before the Edit function selected can be performed.
These tools are Resize, Skew, Rotate, Fillet, and Chamfer.  The Selection
tool and the Point Select tool are used for selecting the objects or groups
of points to be edited.

The Edit tools use the mouse and keyboard entry when working with
objects.  When using the mouse, use a click and drag method.  If the
keyboard entry method is used, the objects or points must first be selected.
Then, double click on the required Edit tool.  The following Edit tools are
the only tools that support keyboard entry.  They are: Selection, Point
Select, Resize, Skew, Rotate, Fillet and Chamfer tools.  The Trim, Zoom and
Text tools do not require any keyboard entry.

Selection Tool

Point Select Tool

Resize Tool

Skew Tool

Trim Tool

Zoom Tool

Text Tool

Rotate Tool

Fillet Tool

Chamfer Tool

The Edit Toolbox



Draw Toolbox

The KeyCAD Pro Draw toolbox is positioned on the left side of the screen
when the program is first opened.  The toolbox can be moved to any position
on the screen.  This feature is very useful when working on large monitors.

To select a tool, place the mouse cursor on the tool and click once.  The icon
then becomes highlighted to show which tool is selected.

The tools found within the Draw toolbox and their proper names are listed
below.  These tools are designed to allow the user to draw individual
objects such as rectangles, circles, polygons, lines, arcs, etc.  Some of these
tools use the click and drag method of drawing, i.e., click and hold down
the mouse button while dragging.  Each tool is explained in greater detail
under the Draw Tools section of this manual.

The Draw tools also allow for keyboard entry of the object size.  This is very
useful for precise construction of designs.  To access the Keyboard Entry
Dialog for a tool, double click on the tool icon  and the Dialog appears. Enter
the object's information in the displayed dialog box.

Rectangle / Square Tool

Oval / Circle Tool

Polygon Tool

Multigon Tool

Arc Tool

Line Tool

Free-formed Spline Tool

The Draw Toolbox



Snap To Toolbox

Almost all technical and engineered drawings require lines, circles, and
rectangles to be drawn in a very precise location, in specific relationships
to each other.  For example, to start a line at the intersection of two different
objects, or draw a line perpendicular to another line.  KeyCAD Pro provides
the user with the Snap To tools to help in locating the precise points required
to create a very detailed and accurate design.

The Snap To toolbox can be positioned anywhere on the screen and it's
display can be turned on or off. This toolbox is not displayed when the
program is first started. It may be turnen on by selecting it from the Toolbox
menuunder the Window menu. A checkmark beside a toolbox name
indicates that it is active.

The Snap To tools are designed to work in combination with the Edit, Draw,
and Dimension tools found within the program.  When using the Snap To
tools with the Draw tools, a line can be started from the end-point of another
line and finish at the center of a circle.  Using the Snap To tools with other
tools ensures that the line or object created starts and ends in the exact
location required.

The sensitivity can also be set to determine how close the mouse cusor must
be to an object for the program to snap to a specific point.  The sensitivity
setting is found in the Preference Dialog under the Edit menu.



The following is a picture of the Snap To tools as they appear in the program.
The names have been listed for the appropriate tool icon.  The name
indicates the Snap To command that is to be performed when using that
particular tool.  These tools should be used in all precise alignment of
objects as well as object start or end-points.

NOTE: Refer to the Snap To Tools section of this manual for a detailed
explanation on how to use these tools.
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Dimension Toolbox

The Dimension tools are designed to help create dimension lines that
appear with witness lines (also called extension lines), which automatically
represent the correct dimension value or measurement.  A  dimension may
contain the size of a particular object or the distance between two separate
objects. Dimension lines can be created for diagonal lines that measure the
vertical or horizontal distance and even the length of the angular line.

One of the most important factors in using these dimension tools, is that
they are designed to work in combination with the Snap To tools.  This
ensures that there is an accurate dimension between two designated points.
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The Readouts
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Readouts (Position Info)

In addition to using the Snap To tools for locating specific points on the
design, the Readouts found at the bottom of the screen can also be used.
The Readouts are designed to assist in specific point locations, angles of
lines, and distance or lengths of objects.  Readouts are primarily designed
to be used with the mouse movements on the screen.

The Readouts are a set of gauges that update automatically with accurate
information as the pointer is moved to draw, edit, select or reposition
objects.  The Readouts are designed to work with English or Metric
measurement and display feet and inches, or decimal equivalence.

Refer to the Readouts to help draw or edit any object.  For example, as the
cursor is positioned to draw an object, the Readouts display the X and Y
coordinates of the mouse cursor, which helps to locate the exact spot to
begin drawing.  As the objects are rotated, the degree of rotation can be
checked while watching the Readouts angle display.

Absolute Coordinates

There are two sets of coordinates, one set reads X, Y coordinates and the
other reads W, H coordinates.  The X, Y displays are called the Absolute
Coordinates.  This means that they track the mouse location from the point
of origin of the screen.  The X, Y coordinates assist in the accurate location
of the start and end-point of the drawing or editing of an object.

Absolute Nudge
Buttons

A set of Absolute Coordinates



Incremental Coordinates

The Incremental Coordinates are displayed with the letter (W) for the
Width and (H) for the Height of any object drawn.

Select a Draw or Edit tool; click to start the selected function. The W, H
readout is automatically set to zero(0) to track the actual movement of the
mouse when drawing or editing an object.

NOTE: The W,H or Incremental Readouts only display and track the start
and end-point of the mouse movements.

Nudge Buttons

The Absolute and Incremental Nudge buttons are shown in the two
previous figures.  These buttons move a selected object by the amount set
in the nudge increment.  Set the nudging rate under the Nudge subheading
found under the Edit menu at the top of the screen. The program defaults
to one pixel nudge rate.

The Absolute Nudge buttons move the selected object according to the
nudge rate.  This does not change the size of the object, but rather changes
the location of the object.

The Incremental Nudge buttons change the width and height of any
selected object.  The center of the selected object is used as a reference
point, and nudges according to the current nudge rate.

Incremental Nudge
Buttons

A Set of Incremental Coordinates



Percentage Readouts

The Percentage readouts are used mainly for the resizing of selected
objects.  When an object is drawn, the percentage display shows 100%,
when the mouse button is released.  This means that the object drawn is at
100% size. If the object is then resized using the Resize tool, there is the
option of resizing by percentage versus using the coordinates. The
readouts display the width and height percentages.

Radius and Diameter Readouts

When arcs or circles are being created, the Radius and Diameter readouts
display an accurate measurement of the radius or diameter of the object
being drawn.

Angle Readouts

This section of the Readouts window, tracks the angular movement of the
cursor.  It is useful when creating angular lines or rotating objects to a
specific angle.

Angle display

Width

Height
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Radius display



Toolbox
Pull- Down Menu

FlipHorizontal

Group

Ungroup
Mirror

Flip Vertical

Lock

Unjoin

Fill Color
Pen Color

Axis Lines

Actual Size

Fit to Window

Grid Lines
 On or Off

Eyedropper Snap to Grid

The Menu Bar (Windows)

 Unlock
Join



The Menu Bar (Macintosh)
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Menu Bar

The Menu Bar permits more efficient work within the design.  The Menu
Bar can be turned On or Off as necessary.  To turn the Menu Bar On or Off,
first pull down the Layout menu and select the Menu Bar command.  Hold
down Ctrl+M to turn the Menu Bar On or Off.

The commands, tools, and options found within the Menu Bar can be
accessed within the various menus found at the top of the screen.

The buttons and pull-down menus have been designed with minimal size.
They are placed along the edge of the title bar to minimize space utilization
and allow an unobstructed design environment.

If the monitor being used is smaller than the width of the Menu Bar, the
program cuts off the options furthest to the right.  It omits one option at a
time, until the width of the Menu Bar fits within the screen size.

The following pages provide a brief definition of each option found within
the Menu Bar.  Refer to the Menu to access further details on selected
options.  The Menus provide detailed examples on how to use these options
while creating a design.  Refer to the Contents Section at the beginning of
the manual for a list of commands contained within each menu.



Mirror

This function permits the selected object to be duplicated and
flipped.  The mirrored object is slightly offset from the original.  To
use the Mirror command, first select the object then click on the
Mirror button within the Menu Bar.  Individual objects or groups
of objects can also be mirrored.

Flip Vertical
This button is used to Flip selected objects along the vertical axis.
It is comparable to flipping the selected object upside down.  It is
possible to flip an Individual object or a group of objects.

Flip Horizontal
This button is used to Flip selected objects along the horizontal
axis. It is comparable to flipping the selected object to the right.  It
is possible to Flip an individual object or a group of objects.

Group
This button is used to consolidate a set of selected objects as one
grouped object.  A grouped set of objects is treated as a single
object, rather than several individual objects.

Ungroup
The Ungroup button automatically divides a grouped object into
individual objects.

Lock
This button is used to Lock the characteristics and location of a
selected object or groups of objects, so that they cannot be
changed.



Unlock
This button is used to Unlock selected objects that were previously
locked.

Join
This button is used to connect (Join) all selected lines or arcs that
share an overlapping (connected) end-point.

Unjoin
This button is used to disconnect all selected lines or arcs that
have been Joined together.

Eyedropper
The Eyedropper button is used to select the current color from any
color within a design.  When the Eyedropper button is clicked on
a color within a design, that color then becomes the current color.
The color selected is then displayed in the Color button.

Fill Color
The current fill color is displayed to the right of this button.  To
select another fill color, click once on the button to open the color
picker.

Pen Color

The current pen color is displayed to the right of this button.  To
select another pen color, click once on the button to open the color
picker.

Grid Lines On or Off

This button is used to turn the Grid Lines On or Off.  This function
is dependent on the current status of the Grid Lines when the
button is clicked.  Set the Grid spacing under the Grid pop-up menu
found under the Layout menu.



Snap To Grid

This button is used to turn the Snap To Grid option On or Off.

Axis Lines On or Off
This button is used to toggle the Axis Lines On or Off.  The Axis
Lines represent the Origin point. This is the reference source for
all Absolute coordinates and readouts.

Fit to Window

This button allows the program to automatically fit the entire
design within the current window size.  This is useful for the overall
layout of a design.

Actual Size

Click on this button to display a design at its actual size.  This is
useful when the user has Zoomed In or Out and wishes to return
to the Actual Size without using the Zoom tool or Menu command.
To access the keyboard equivalent for Actual Size, press CTRL E.
The Menu command is found under the Options menu.

New Image  (Macintosh only)

This button is used to create a new image at the default settings.
Selecting this button is the same as selecting the File menu, New
option.

Open Image  (Macintosh only)
This button displays the Open Image window.You can locate and
open previously created documents.

Save  (Macintosh only)

This button allows you to save the currently active file. If the file
has been saved previously then this button saves the document
over the original document.



Print  (Macintosh only)

This button displays the print dialog box. This dialog box allows
you to set printer options and print the currently active document.

Cut  (Macintosh only)

This button removes selected objects from a document and places
them on the clipboard.

Copy  (Macintosh only)

This button places the selected objects in the clipboard while
leaving the original objects in the document.

Paste  (Macintosh only)

This button places the contents of the clipboard into the currently
active document.

Line Type  (Macintosh only)

This button allows you to select a line style for any selected
objects.

Fill Patterns  (Macintosh only)

This button displays the Fill Pattern Window.

Import Image  (Macintosh only)

This button allows you to import a previously saved image into
the currently active image.



Toolbox Pull-Down Menu

This pull-down menu is used to turn On
or Off any of the toolboxes found within the
program.

The Toolbox Pull-Down Menu



The Edit Toolbox

The Edit tools offer the ability to edit or change any object that has been
created within the program, in addition to designs that were imported from
elsewhere.  When working with imported designs, verify that the design is
in a vector format, NOT a raster format such as paint files. The way that
the Edit tools work, is by selecting the individual or groups of points that
are to be edited. Points may be selected by clicking on the individual vertex
points of the object or by dragging a selection rectangle around the points
to be edited.

The Edit tools offers the following types of functions: Selecting Objects,
Individual point selection, Resizing of objects, Skewing objects to any
angle, Rotating objects from 0 to 360 degrees, Fillet and Chamfer
capabilities, Trimming of objects, Zooming and Text.

To maintain a high level of accuracy, the Edit tools can be combined with
the Snap To tools which are also found within the program.  The Snap To
tools are designed to work in conjunction with all of the tools found within
the program.  Refer to the Snap To Tools section of this manual for more
details concerning these tools.

This section of the manual offers a detailed explanation of each Edit tool
capability as well as some step by step instructions on how to use the Edit
tools.



Edit Tools and Individual Names

The following diagram shows a complete list of all the Edit tools and the
proper name for each tool.  It is very important to learn their proper names.

Selection Tool

Point Select Tool

Resize Tool

Skew Tool

Rotate Tool

Fillet Tool

Trim Tool

Zoom Tool

Text Tool

Chamfer Tool

The Edit Tools



Selection Tool

The Selection tool is primarily used for repositioning selected objects to
any location within the design. This tool is used to select and move
individual or groups of objects anywhere within the design area.

This tool is the first tool in the Edit toolbox, and is sometimes called a
Cursor tool.  The tool works in two different fashions when selecting
objects.  First, click on any part of an object to highlight the object.  (more
objects can be added by holding down the SHIFT key when clicking on
additional objects).   The second method of selection is to drag a selection
rectangle around the object or group of objects.

If there is a specific location that is to be entered when moving objects, do
so by using Keyboard Entry.  This is explained later in this section under
the subheading Keyboard Entry.

Selecting Objects

One of the most common ways of selecting objects is to click on a part of
the object.  After clicking on the object, the vertex points become
highlighted.  The object may then be relocated anywhere on the screen by
clicking and dragging on a line in the object.  When dragging the object a
ghost line appears, which represents the boundary lines of the object or
objects selected.

NOTE:  Perfect horizontal or vertical movement can be achieved by
holding down the SHIFT key while dragging the object.



Example 1

The following example provides further explanation on how to use the
Selection tool by clicking on an object.

Step 1

Create a simple object as shown below, then place the cursor on top of the
object as shown and click the mouse button once.

Step 2

Once the mouse button is clicked, the vertex points of the object are
highlighted as shown below.

Step 3

Now that the object is selected, it can be moved.  While keeping the cursor
on top of the selected object hold down the mouse button and begin
dragging the object to a different location.  The ghost lines then appear to
help align the object with other objects.  Perfect horizontal or vertical
movement can be acheived by holding down the SHIFT key while dragging
the object.

Click mouse once

Selected vertex points

Ghost lines



Example 2

The following example provides further explanation on how to use the
Selection tool with a selection rectangle.

Step 1

Create a simple object as shown below, then click on the Selection tool
within the Edit toolbox.  Now place the cursor near the object (as shown
below) and hold down the mouse button while dragging the mouse.  This
creates the selection rectangle and therefore selects any objects within the
selection rectangle.  This method is suited for selecting multiple objects to
be moved together.

Step 2

Once the objects have been selected, the vertex points of the objects are
highlighted as shown below.

Step 3

Now that the object is selected, it can be moved.  While keeping the cursor
on top of the selected object hold down the mouse button and begin
dragging the object to a different location.  The ghost lines then appear to
help align the object with other objects.  Perfect horizontal or vertical
movement can be acheived by holding down the SHIFT key.

Selection Rectangle

Selected vertex points



Keyboard Entry with Selection Tool

When using the Selection tool there is the option of using Keyboard Entry.
This is advantageous because it allows the user to enter the coordinates for
a specific location to move an object to.  To access the Selection tool Dialog
box, double click on the Selection tool icon.

To move an object, it must first be selected. If no object is selected, snap
to a point on the object, then press ENTER.  This allows the program to
determine which point of the object should be placed at the new coordinates.
When snapping to the required point be sure to use the Snap To tools to
assure complete accuracy when moving the object.  The Dialog box offers
a choice of Cartesian or Polar coordinates.

NOTE: The typed coordinates are relative to the object's current position.

The Selection Tool Dialog box



Point Select Tool

The Point Select tool is primarily used for repositioning individually
selected points to any location within the design.  To maintain perfect
accuracy in working with the Point Select tool, combine this tool with the
Snap To tools.  This tool is the second tool in the Edit toolbox, and is also
known as a Cursor tool.

There is the option to specify any X, Y coordinates by using Keyboard
Entry rather than the mouse.  Keyboard Entry is explained in greater detail
later in this section.

Selecting points with the Point Select tool

This tool works in two different ways when selecting objects.  First click
on any individual vertex point within an object; therefore highlighting just
that point.  (Individual points may be added by holding down SHIFT
when clicking on additional vertex points.)

The second method of selection is to drag a
selection rectangle around the individual point or
groups of points to be selected.

When the points are highlighted, place the cursor on top of a selected point
within the object, hold down the mouse and move these points to any
location on the screen.  When dragging these points, a ghost line appears
representing the boundary lines of the points selected.   Perfect horizontal
or vertical movement can be achieved by holding down SHIFT after the
dragging of the selected points has started.

Selection
Rectangle



Example

The following example shows how the Point Select tool can help in editing
designs.  A simple closet layout has been created for this purpose.  It is
possible to use any design or create a similiar design to the one below.

Step 1

After a design is created, select the Point Select tool from the Edit toolbox.
Now drag a selection rectangle around the end of the closet as shown
below.  Once selected, the individual points are highlighted, and can be
moved as required.

Closet

Closet

Selection
Rectangle

An Example of a Closet Layout

An Example of the Point Select Tool



Step 2

Place the Point Selection tool cursor on top of a highlighted point as shown
below.  After placing the cursor on top of the point, hold down the mouse
button and drag the selected points to the left.  Watch the readouts at the
bottom of the screen for precise movement.  Remember that SHIFT can be
held down to constrain movement horizontally.

Step 3

Once the desired distance has been reached, release the mouse button and
the design is automatically updated to reflect the changes.  This is a very
useful tool for updating previously drawn designs.

Closet

Closet

Hold down mouse button
and drag to the left



Keyboard Entry with Point Select Tool

The Point Select tool has the option of using Keyboard Entry for a very
precise movement.  This means that if it is necessary to move any point or
group of points to a specific location (XY Coordinates), it can be done
easily.  To access the Point Select tool Dialog box, double click on the Point
Select tool icon.

It is important to remember that when moving selected points using
Keyboard Entry, the points to be moved must be selected first.  After
selecting the points, snap to one of the selected points, then press ENTER.
This allows the program to determine which point of the object should be
placed at the new coordinates.  When snapping to the desired point be sure
to use the Snap To tools within the Snap To toolbox for complete accuracy
when moving the selected points.  The Dialog box allows a choice of
Cartesian or Polar coordinates, as well as Relative or Absolute reference
coordinates.

NOTE: The Absolute coordinates entered are in reference to the point of
origin of the working design.  The program initially sets the origin to the
lower left-hand corner of the design.

The Point Select Dialog box



Resize Tool

When using the Resize tool the horizontal and vertical widths of any object
can be changed.  Also when using the Resize tool either the mouse or
Keyboard Entry can be used.

In using the mouse, click and drag the corner of the object to be resized.  The
readouts at the bottom of the screen can be used to maintain any specific
size.  While resizing objects, ghost lines appear for visual representation.

If the Keyboard Entry method is used, first select the object and then double
click the Resize tool icon to access the Keyboard Entry Dialog box.  Once
the Dialog box appears enter the new width and height of the object.

Selecting an object for resizing

First select the Resize tool from the Edit toolbox, then place the cursor on
the object and click the mouse button.  The points of the object then become
highlighted and are ready for resizing.

If there are multiple objects that make up one design and all of them are to
be resized together, drag a selection rectangle around those objects to
highlight the object's vertex points.

Example

Point and click Selection Rectangle



The following example shows how to resize the window that was just
created.  Notice that the window is made up of multiple objects such as lines
and rectangles.  Therefore, to select the window, drag a selection rectangle
around the entire window as shown below, to highlight the points within the
window.

Step 1

First, drag the selection rectangle around the window to highlight the points
within the window.

Step 2

Be sure that the Resize tool is selected, then place the cursor on top of the
corner point as shown below.  This is the point to be dragged to resize the
window.  The opposite point is used as the anchor point when resizing.  This
means that the point stays in its original position, while dragging the other
point.

Step 3

Point being dragged

Anchor point

The Selection Rectangle



Now hold down the mouse button and begin dragging.  The ghost lines
appear as a visual reference for resizing the window.  Watch the readouts
at the bottom of the screen to maintain a specific size.  Release the mouse
button at the desired size.

Keyboard Entry with Resize Tool

When resizing objects there is the option to use numeric Keyboard Entry.
This is very helpful when an object is to be resized to a specific size.

To access the Resize tool Dialog box, double click the Resize tool icon.
When using Keyboard Entry with the Resize tool, an object must first be
selected.  The Resize Dialog offers the option to resize by Percentage or by
Object size. The Dialog box also specifies from which part of the object the
resizing is to be done.

Window after resizing

Ghost lines

Drag the mouse to the
desired size

The Resize Tool Dialog box



Skewed Object

Skew Tool

This tool is designed to give any selected object a skewed angle.  When this
tool is used, the selected object takes on an angular shape.

The Skew tool supports the mouse as well as numeric Keyboard Entry.
When using the mouse, first select the entire object so that the vertex points
are highlighted.  Next place the mouse cursor on top of a highlighted vertex
point; then click and drag to a desired angle.  When using the mouse a ghost
line appears to give a visual representation of the object as it is being
skewed.  Watch the readouts at the bottom of the screen to obtain the
necessary angle.

Example
Step 1

Create a shape similiar to the one shown below.  Then select the object so
that the vertex points are highlighted.  Now place the cursor on the top point
of the triangle, then click and drag the cursor to the left as shown below.

Step 2

At the desired distance or angle release the mouse button.  This example
shows a triangle skewed by a 30 degree angle.

Ghost lines



Keyboard Entry with Skew Tool

The second method of using the Skew tool is with the numeric Keyboard
Entry.  Using Keyboard Entry is useful when an object is to be skewed to
a specific angle.

Before accessing the Skew tool Keyboard Entry Dialog box, select an
object.  Then double click on the Skew tool icon and the Dialog box
appears.  Type in the required angle and click the OK button.  The selected
object is automatically updated to reflect the new changes.  The Dialog box
offers the option to choose which direction to skew the object.  Choose
from Up, Down, Left or Right.  The Distance entry determines how far the
object is skewed.

The Skew Tool Dialog box



Rotate Tool

By using the Rotate tool any object can be rotated from 0 to 360 degrees.
All objects are rotated from their centers.  Rotating objects can be
performed by two methods; the mouse or Keyboard Entry.

The following example shows how to use the Rotate tool with the mouse.

Example
Step 1

First create an object similiar to the one shown below.  Then select the
object so that the vertex points are highlighted.

Step 2

Place the cursor on the corner vertex point, then click and drag the mouse
in a counter clockwise direction.  Once the dragging is started, a ghost line
appears representing the boundaries of the object.  At the desired rotation
release the mouse button.  Watch the readouts at the bottom of the screen
for the degree of rotation.

Begin dragging
the mouse

Rotated object

Highlight object



Keyboard Entry with Rotate Tool

There is the option to rotate any object or group of objects by using numeric
Keyboard Entry.  An object must be selected before accessing the Keyboard
Entry Dialog.  After selecting an object, double click on the Rotate tool
icon.  Once the Dialog box appears any degree of rotation can be entered.
There is also an option to choose either Degrees or Radians.  After the
correct information is entered click on the OK button.

NOTE: The program allows the rotation of individual objects or groups of
objects when using Keyboard Entry.  Be sure to have all the necessary
objects selected before accessing the Dialog box.

The Rotate Tool Dialog box



Fillet Tool

When using the Fillet tool, a radius can be added to any object.  Remember
that the Fillet tool works with corner points of an object.  What this means
is that before a fillet can be applied with the Fillet tool, the selected corner
point must be joined together or made of enclosed objects such as
rectangles, squares, polygons, etc.  The example shown below gives a
further explanation.

Example 1

With the two lines shown below, the Fillet tool cannot be used to apply a
radius between the end-points of the two lines.  In this instant the Arc tool
from the Draw toolbox would be used, then snap each end of the arc to the
end-points of the two lines.  For more information concerning the Arc tool
refer to the Draw Tools section under the Arc tool subheading.

The rectangle shown below is the type of object that the Fillet tool is used
with.  The reason the Fillet tool works on the rectangle is because the corner
points are joined together and make up one vertex point rather than two as
shown above.

Apply the Fillet tool to corner
vertex points which are joined

Arc tool

Use Arc tool to apply a radius
between two separate end-points



Using the Fillet tool

The following example guides the user through the proper usage of the
Fillet tool.  This tool works with the mouse and allows the user to enter a
precise radius with the numeric Keyboard Entry.

Example 2
Step 1

First, create a shape similiar to the one shown.  The object shown below has
been created with the Rectangle tool.  After creating a shape, select the
Fillet tool from the Edit toolbox and click on the corner vertex point as
shown below.

Click on corner vertex point

Step 2

Now hold down the mouse button and begin dragging the cursor towards
the center of the rectangle as shown below.  Watch the readouts at the
bottom of the screen to maintain a specific radius.  At the desired radius,
release the mouse button.  The design is automatically updated to reflect the
filleted corner.

Drag cursor towards the center
of the rectangle

Release mouse button
to display the radius



Keyboard Entry with Fillet Tool

The Fillet tool has the ability to be used by typing in the radius with
numeric Keyboard Entry.  The Dialog box is used to type in the exact
radius and to select from a Standard fillet or an Inverse fillet.

The Fillet tool can select points in two ways.  One is to place the Fillet tool
cursor on top of the corner point and click the mouse button one time.  The
second method is to use the Fillet tool and drag a selection rectangle around
the point(s) to apply a fillet to.

When using Keyboard Entry with the Fillet tool, the point(s) must be
selected before activating the Dialog box.  To access the Fillet tool Dialog
box first select the points then double click on the Fillet tool icon.  After the
correct radius have been entered and the standard or inverse fillet chosen,
click the OK button.

Standard Fillet
Inverse Fillet

The Fillet Tool Dialog box



Chamfer Tool

When using the Chamfer tool, an angular corner can be applied to any
object.  Remember that the Chamfer tool works with the corner points of
an object.  What this means is that before a chamfer can be applied with the
Chamfer tool, the corner point selected must be joined together or made of
enclosed objects such as rectangles, squares, polygons, etc.  The example
below offers further explanation.

Example 1
With the two lines shown below, the Chamfer tool cannot be used
to apply a radius between the end-points of the two lines.  In this
instance the Line tool from the Draw tools is used, then snap each
end of the line to the end points of the separated lines.  For more
information concerning the Line tool refer to the Draw Tools
section under the Line tool subheading.

The rectangle shown below is the type of object that can be used with the
Chamfer tool.  The reason the Chamfer tool works on the rectangle is
because the corner points are joined together and make up just one vertex
point rather than two as shown above.

Apply the Chamfer tool to
corner vertex points which are joined

Use Line tool to apply a
chamfer between two
separate end-points

The
Draw
Toolbox

Line tool



Using the Chamfer Tool

The following example goes through the proper usage of the Chamfer tool.
This tool works with the mouse and enables the user to enter a precise
length and angle of the chamfered corner, when using the numeric Keyboard
Entry.

Example 2
Step 1

First create a shape similiar to the one below.  The shape below has been
created with the Rectangle tool.  After creating a shape, select the Chamfer
tool from the Edit toolbox and click on the corner vertex point as shown
below.

Click on corner vertex point

Step 2

Now hold down the mouse button and begin dragging the cursor towards
the center of the rectangle as shown below.  Watch the readouts at the
bottom of the screen to maintain a specific length.  At the desired chamfer,
release the mouse button.  The design is automatically updated to reflect the
chamfered corner.

Drag cursor towards the center
of the rectangle

Release mouse button to
display the chamfer



Keyboard Entry with Chamfer Tool

The Chamfer tool has the ability to be used by typing in the length of angle
with numeric Keyboard Entry.  The Dialog box allows the user to type in
the length of the chamfer.

The Chamfer tool can select points in two ways.  One is to place the
Chamfer tool cursor on top of the desired corner point and click the mouse
button once.  The second method is to use the Chamfer tool and drag a
selection rectangle around the point(s) to which a chamfer is to be applied.

When using Keyboard Entry with the Chamfer tool the point(s) must be
selected before activating the Dialog box.  To access the Chamfer tool
Dialog box first select the points then double click on the Chamfer tool
icon.  After the correct length has been entered, click the OK button.

The Chamfer Tool Dialog box



Trim Tool

The Trim tool is useful for cutting objects or trimming away segments of
objects that would otherwise require the user to redraw, resize or edit in
some fashion.  The Trim tool quickly assists in the cutting of lines,
rectangles, polygons as well as the outlines of arcs or circles.

When the Trim tool is selected from the Edit toolbox, the cursor turns into
a crosshair.  When the crosshair is placed on a line and the mouse button
is clicked, the Trim tool inserts a vertex point therefore breaking the line.

The following example explains how to properly use the Trim tool.

Example
Step 1

First select the line to be trimmed and then select the Trim tool from the Edit
toolbox and place the cursor at the required point to trim the excess line,
as shown below.  Then click the mouse button.

Excess hangover to
be trimmed

Place cursor at trim point
and click mouse



Step 2

Once the mouse has been clicked, a highlighted vertex point appears.  This
indicates that the program has trimmed the excess line at the highlighted
point.

Trimmed point

Step 3

After trimming the line as explained in the previous steps, the excess line
can then be deleted.  To delete the excess line, first select the Selection tool
from the Edit toolbox and click once on the excess line, then press DEL.

Trimmed object

NOTE: Be sure that when DEL is pressed, no other objects are selected
simultaneously.  If any objects other than the trimmed line are selected, all
the selected objects are removed.



Zoom Tool

The Zoom tool is used to change the
level of enlargement or reduction of the
drawing view. It would be the same as
using a magnifying glass when looking at
a design. It is very useful to zoom in
on a drawing for a close view of details
or to zoom out for an overview of the
drawing layout.
The program offers several ways to use
the Zoom tool for zooming In or Out.
The percentage of zoom can also be set
within the Preference Dialog found under
the Edit menu.

When the program is started initially, the Zoom tool defaults to a plus sign
in the center of the icon.  This indicates that this tool is set to zoom in.  The
plus sign can be changed to a minus sign by holding down the SHIFT
(or OPTION key on a Macintosh), after the Zoom tool is selected, thus
allowing the user to zoom out.

Another way to use the Zoom tool is to click and drag with the Zoom tool,
therefore creating a Regional zoom. This means that the area within the
selection rectangle created by dragging the Zoom tool, magnifies to the full
screen size.

Zooming In

Select the Zoom tool from the Edit toolbox and place it over the point to
zoom in on, then click the mouse button.  The percentage of zoom can be
set, which determines the degree by which the screen zooms each time the
mouse is clicked.  (The Zoom Percentage setting is found in the Preference
Dialog under the Edit menu.)

Place Zoom tool at the
point to zoom in at

Zoom +  icon

Regional Zoom

Zoom -  icon



Zooming Out

Select the Zoom tool from the Edit toolbox and place it over the point to
zoom out.  The percentage of zoom can be set, which determines the degree
by which the screen zooms each time the mouse is clicked.  The Zoom
Percentage setting is found in the Preference Dialog under the Edit menu.

Once the Zoom tool is selected, hold down SHIFT (or OPTION on a
Macintosh) to change the magnifying glass from a + (plus)  to a - (minus).
Now click the mouse button and the screen zooms out.  Repeat this process
as many times as necessary.

Place Zoom tool
at the point
to zoom out

Regional Zoom

To use this method of zooming, first select the Zoom tool from the Edit
toolbox.  Now hold down the mouse button and drag a selection rectangle
to select the part of the design to be magnified. The area identified within
the selection rectangle is displayed to the maximum size of the screen.  The
magnification factor is determined by the size of the area selected.

Drag a selection rectangle



   Text Tool

This tool can be used to add captions and paragraphs of text to any
drawing.  The user can mix fonts, font sizes and font styles.

The Text Menu

Before text is typed within a design, choose the font, font size, font style,
and text alignment that are appropriate for the document.  The program
supports any font that is installed within the operating system.  KeyCAD
Pro also supports TrueType and PostScript fonts.  Text can be aligned
along the left or right margins, or centered  between margins.

KeyCAD Pro's pop-up dialog allows fast access when selecting the
desired text.  To access the pop-up dialog, pull down the Text menu and
choose the Fonts... option  and select from options such as: Font, Size, or
Style.

Adding Text to a document
1. Choose a font from the Font menu.
2. Choose a font size from the Size menu.
3. Choose a font style from the Style menu
4. Choose align Left, Right, or Center from the Text menu.

After the choices are made, select the Text tool from the Edit toolbox and
add text to any part of the design.  KeyCAD Pro defaults to Arial 12-point
text with left alignment when the program is initially started.



Moving Text Blocks

The creation of a text block is used to move the text to a preferred location.
To do this, select the Selection tool from the Edit toolbox, and click on the
text that has been already created.

Editing Text within a Text Block

Text can be selected within a text block for editing purposes.  To select part
of a text object, first select the Text tool from the Edit toolbox.  Then select
the letters or words to be edited by dragging through the text.  The selected
text becomes highlighted and can now be edited.

Drag I-beam through the text
to highlight individual words
or letters

Deleting a Text Block

An entire text block can be deleted at one time.  First, select the Selection
tool from the Edit toolbox.  Then, click once on the text block to be deleted
and press DEL.

Click on the text to
highlight text block



The Draw Tools

The Draw tools are used in the construction of basic shapes,
that can be combined together to create complex shapes.  The
Draw tools consist of rectangles, squares, circles, ovals,
polygons, multigons, arcs, lines, and free-formed splines.  The
Draw toolbox automatically appears to the left side of the
window when the program is first started, but the toolbox can
be relocated to any position on the screen.

To select a tool for drawing with the mouse, click once on the
required tool, then click and drag the mouse to construct the
selected object.

To access the Draw tools Numeric Keyboard Entry Dialog, double click
on the tool icon.

These two methods of selection work the same for all Draw tools.

The Draw toolbox can be turned On or Off for convenience.  Toolboxes
can be turned On or Off under the Tools pull-down menu on the Menu Bar,
or the Toolbox pop-up menu found under the Windows menu.

Combining Draw Tools with Snap To Tools

The Draw tools are designed to work in conjunction with the Snap To tools.
This allows the user to precisely snap to end-points, midpoints, etc. when
starting and finishing the objects found in the Draw toolbox.



Rectangle / Square Tool

The Rectangle / Square tool is designed to draw both rectangles and
squares.  KeyCAD Pro defaults to the Rectangle tool.  To draw squares,
select the tool icon and hold down SHIFT  when using the tool, to draw
perfect squares.

Rectangle Tool combined with Snap To Tools
The Rectangle / Square tool can be used with the Snap To
tools, allowing the rectangle or square to start or end from
another object's center, midpoint, end-point, percentage point,
etc.  Remember that any rectangle or square can start or end
from any of the Snap To tools.  Use the Tab key to change
Snap To tools when dragging the mouse to create selected
objects.

The rectangle or square can be drawn from the objects center
point.  The Draw from Center can be selected as an option
under the Layout menu.  When this option is selected, the tool
draws the object double the size of the Incremental Readouts
or the distance the mouse (width and height) is dragged.

Rectangles
Squares

Draw from Center  is located under the Layout menu



Drawing a Rectangle/Square with the Mouse

The following instructions explain how to construct a rectangle or square,
while using the mouse.

1. Select the Rectangle/Square tool from the Draw toolbox.
2. Place the cursor at the required start point, and click and drag

the mouse until the desired size is obtained.  Watch the
readouts at the bottom of the screen for the object size.  The
W indicates the objects width, and the H indicates the object
height.

The Absolute coordinates display the object size added to the Absolute
coordinates of the start point.  This means that the coordinates are
calculated from the Origin point (Axis Lines Intersection).

The Incremental readouts display the object size in relation to the start
point.

Absolute Readouts Incremental Readouts
(Object Size)



Using Keyboard Entry with Rectangle/Square Tool

The Rectangle/Square tool Numeric Keyboard Dialog can be selected  by
double clicking on the tool icon.  A Dialog box appears, allowing the user
to numerically enter the object size and start point.

After double clicking on the tool, the Numeric Entry Dialog box appears,
it disregards the mouse actions and the object is drawn to the numeric
information entered in the Dialog box.  The object width and height  as well
as the start point of the rectangle or square can be set.

Start Point

When setting the start point, first select the Start Point button, notice that
the Dialog box information changes to coordinate positions.  When the
coordinate positions are entered, the start point can also be set to be at a
selected point on the object such as, Upper Left, Upper Right, Lower Left,
Lower Right, or Center point of the rectangle or square.  The start point is
always relative to the Absolute Point of the document.

Start Point
coordinates

The Rectangle/ Square Tool Dialog box



Object Size

When the Object Size button is clicked the Dialog changes, so that the
object's width can be entered.  Remember that the Object Size information
is taken from the selected Draw From and Start Point coordinates.

If the Draw From Center option is selected, the width and height are
reduced to half the actual size.

Object Size Info

The Object Size Dialog box



Circle / Oval Tool

The Circle / Oval tool is designed to draw both circles and ovals.
KeyCAD Pro defaults to the Oval tool.  To draw perfect circles, select the
tool icon and hold down SHIFT while using the tool to draw perfect
circles.

Circle/Oval Tool combined with Snap To Tools
The Circle / Oval tool can be used with the Snap To tools,
therefore allowing the user to start or end the objects from
another object center, midpoint, end-point, percentage point,
etc.  Remember that any circle or oval can start or end from
any of the Snap To tools.  Use the Tab key to change Snap To
tools when dragging the mouse to create selected objects.

A circle or oval can also be drawn from the object center
point.  The Draw From Center option can be selected from
under the Layout menu.  When this option is selected, the tool
draws the object and doubles the size of the Incremental
Readouts or the distance the mouse (width and height) is
dragged.

Draw from Center  is located under the Layout menu

Circle Oval



Drawing a Circle or Oval with the Mouse

The following instructions explain how to construct a circle or oval, while
using the mouse.

1. Select the Circle/Oval tool from the Draw toolbox.

2. Place the cursor at the desired start point and click and drag
the mouse until the desired size is reached.  Watch the
readouts at the bottom of the screen for the object size.  The W
indicates the object width, and the H indicates the object
height.

The Absolute coordinates display the object size added to the Absolute
coordinates of the start point.  This means that the coordinates are
calculated from the Origin point (Axis Lines Intersection).

The Incremental Readouts display the object size in relation to the start
point.

 Incremental Readouts
(Object Size)

Absolute Readouts



Using Keyboard Entry with Circle/Oval Tool

The Circle/Oval tool Numeric Keyboard Entry Dialog box can be accessed
by double clicking on the tool icon.  A Dialog box appears, allowing the
object size, start point, radius and diameter to be entered.

After double clicking on the tool and the Numeric Keyboard Entry Dialog
appears, the Dialog box disregards the mouse actions and the object is
drawn to the numeric information entered in the Dialog box.

Start Point

When setting the start point, first select the Start Point button, notice that
the Dialog box info changes to coordinate positions.  When the coordinate
positions are entered the start point can also be set to be at a selected point
on the object such as Top, Left, Right, Center and Bottom of the circle or
oval.  The start point is always relative to the Absolute Point of the
document.

Start Point
coordinates

The Oval / Circle Tool Dialog box



Object Size

When the Object Size button is clicked the Dialog changes, so that the
object width and height can be entered.  Remember that the Object Size
information is taken from the selected Draw From and Start Point
coordinates.

The Circle/Oval tool has the options of using Radius, Diameter or Object
Size for creating the object.  Select one of the options after the Start Point
and Draw From options have been set.

If the Draw From Center option is selected, the width and height of the
circle or oval are reduced to half of the actual size.

Object Size
Info

The Oval / Circle Tool Dialog box



Polygon Tool (Open and Closed)

The SHIFT key together with the Polygon tool constrain each segment
to a perfect Horizontal or Vertical line.

The Polygon tool is designed to draw Open or Closed polygons, that can
contain many individual sides.  Polygon shapes are often closed shapes,
which means that the last line connects with the beginning point of the
polygon.  Closed polygons include triangles, parallelograms, stars, octagons,
and many other shapes.

A Closed Polygon

A Open Polygon

Polygon Tool combined with Snap To Tools
The Polygon tool can be used with the Snap To tools, therefore
allowing the user to start or end polygons from another object's
center, midpoint, end-point, percentage point, etc.  Remember
that any polygon can start and end from any of the Snap To
tools.  Use the Tab key to change Snap To tools when
dragging the mouse to create selected polygons.

To use a Snap To tool with the polygons start point, first select
the required Snap To tool, then select the Polygon tool and
place the start point.  To finish the polygon at a specific Snap
To tool, press the Tab key to change the Snap To tool while
drawing the polygon, and double click at the desired end-point.



Creating a Polygon with the Mouse

1. Select the Polygon tool from the Draw toolbox, then place the
crosshair cursor at the desired start point.

2. Click the mouse button once, to set the first point.  Then drag
the mouse to the second point location and click the mouse
button.  Repeat this process as many times as necessary.

3. When the polygon is completed, double click the mouse
button to end the polygon.  If the end-point is within a 10
pixel radius of the start point, the polygon is automatically
closed.  If the end point is outside of the 10 pixel radius, the
polygon ends at the point clicked, creating an open polygon.

Once either an Open or Closed Polygon have been created, it can be filled
with any of the fill patterns available.  The line type and size that make up
the boundaries of the polygon can also be changed.  Lines can be changed
from under the Layout menu, in the pop-up menu called Lines.

The Lines pop-up menu

The color of the polygon can also be changed by selecting the polygon and
then choosing a new color from the color dialog.  If the polygon has been
filled and the colors changed, the fill then reflects the color changes,
therefore allowing for colored fills.



Using Keyboard Entry with the Polygon Tool

When using the Polygon tool the user has the option of using numeric
Keyboard Entry, instead of the mouse.  To access the Dialog box, double
click on the Polygon tool icon.

Within the Polygon tool Dialog box, choose from Open or Closed polygons
and set the start point of the polygon and the number of points within the
polygon.  Choose from Cartesian or Polar coordinates.  The Dialog box
also displays which point is being entered, as well as the total number of
points making up the polygon.

After entering a point coordinate press the Enter Point button to place and
add the new point to the polygon.  Continue adding points as necessary.  At
the desired number of points, click on the End Polygon button,to
automatically end the polygon.  Click the OK button to close the Dialog
box.

The Polygon Dialog box



Multigon Tool

The Multigon tool is designed to draw objects that contain  any number of
sides, with each side of equal length.  This tool is used to create octagons,
pentagons, triangles, etc.  This tool saves a lot of time in creating various
multigons.  Other programs usually use the Polygon tool for creating
multigons.

KeyCAD Pro defaults the Multigon tool to contain five even sides.  The
number of sides can be changed in the Preference Dialog, which is found
under the Edit menu.

Different objects created with the Multigon tool

Multigon Tool combined with Snap To Tools
The Multigon tool can be used with the Snap To tools,
therefore allowing the user to start or end the multigon from
another object center, midpoint, corner, percentage point, etc.
Remember that any multigon can start or end from any of the
Snap To tools.  Use the Tab key to change Snap To tools when
dragging the mouse to create the multigon.

The multigon can also be drawn from the object's center point.
The Draw From Center option can be selected from the
Layout menu.  When this option is clicked, the tool draws the
multigon double the size of the Incremental Readouts or the
distance the mouse (width and height) was dragged.

Draw from Center  is located under the
Layout Menu



Drawing a Multigon with the Mouse

The following instructions explain how to construct a multigon, while
using the mouse.

1. Set the number of required sides for the multigon. The
number of sides can be set within the Preference Dialog under
the Edit menu.

2. Second, select the Multigon tool from the Draw toolbox.

3. Now, place the cursor at the required start point, and click
and drag the mouse until the desired size is obtained.  Watch
the readouts at the bottom of the screen for the multigons
width.  The W indicates the object width, and the H indicates
the object height.

NOTE: The start and end-point of the Multigon can snap to any of the
Snap tool options.

The Absolute coordinates display the object size added to the distance the
cursor is from the absolute point of the document.  The Absolute Readouts
track the mouse movement in relation to the Origin point.  This means that
the coordinates are calculated from the Origin point (Axis Lines Intersection).

The Incremental Readouts display the object size in relation to the start
point or the distance the mouse is dragged.

Absolute Readouts Incremental Readouts
(Object Size)



Start Point
Info

The Multigon Tool Dialog box

Using Keyboard Entry with the Multigon Tool

The Multigon tool Numeric Keyboard Entry Dialog box can be accessed
by double clicking on the tool icon.  A Dialog box appears, allowing the
user to numerically enter the object size and start point.

After double clicking on the tool, the Numeric Keyboard Entry Dialog box
appears.  It disregards the mouse actions and the object is drawn to the
numeric information entered in the Dialog box.  The size and start point of
the multigon can be set.  The Draw From button is the point on the multigon,
which is placed at the Start Point coordinates.



Start Point

When setting the start point, first select the Start Point button, notice that
the Dialog box information changes to coordinate positions.

Start Point coordinates

When the coordinate positions are entered the start point can be set to be
at a selected point on the object such as Top, Left, Right, Center and Bottom
of the multigon.  The start point is always relative to the Absolute Point of
the document.  If the Draw From Point is selected, the multigon doubles the
width typed in the Total Width Entry box.

Object Size

When the Object Size button is clicked, the Dialog changes, so that the user
can enter the multigons width.  Remember that the Object Size information
draws from the selected Draw From and Start Point coordinates.

The Multigon tool Dialog has the option to enter the number of sides that
make up the multigon.  Remember, that each side is even in length.

If the Draw From Center option is selected, the width and height of the
multigon, is twice the Total Width entry.

Click on the OK button once the correct information is entered.  The Cancel
button can be used to exit the Dialog and cancel the multigon drawing.



Arc Tool

The Arc tool is designed to draw both elliptical and 90 degree arcs.
KeyCAD Pro defaults to the elliptical Arc tool.  To draw perfect circular
arcs, select the tool icon and hold down SHIFT when using the tool.

An Elliptical Arc A Circular Arc

Arc Tool combined with Snap To Tools
The Arc tool can be used with the Snap To tools, therefore
allowing the user to start or end the arc from another object
center, intersection, end-point, percentage point, etc.
Remember an arc can start and end from any of the Snap To
tools.  Use the Tab key to change Snap To tools when
dragging the mouse to create selected objects.

The example above shows how the Arc's start point was snapped to the end-
point of a line, and the end-point of the Arc was snapped to the corner point
of the rectangle.



Using the Arc Tool with the Mouse

Arcs can be created in two ways while using the mouse button.  The two
types of arcs are elliptical arcs and perfect 90 degree arcs.

Creating an Elliptical arc

1. Select the Arc tool from the Draw toolbox.
2. Now, place the crosshair cursor at the desired start point, then

click and drag the mouse.  Note how the arc follows the
crosshair cursor, allowing the user to change the length and
height of the arc.

3. At the desired arc, release the mouse button.

NOTE: The start and end-point of the arc can be snapped to any of the
Snap To tool options.

Creating a Circular arc

1. Select the Arc tool from the Draw toolbox.
2. Then, place the crosshair cursor at the desired start point.
3. Now, click and hold down the mouse button while dragging

the mouse.  When dragging the mouse hold down SHIFT
and release the mouse button. A straight line from the start
point to the cursor appears representing the radius of the arc.

4. Drag the cursor in a clockwise or counter clockwise direction
and watch the arc being created.  Press the mouse button once
to end the arc.

Elliptical arc

90 degree arc



Using Keyboard Entry with the Arc Tool

The Arc tool Numeric Keyboard Entry Dialog box can be accessed by
double clicking on the tool icon.  A Dialog box appears, allowing the user
to enter the type of the arc, and set the start and end points.

After double clicking on the Arc tool the Numeric Keyboard Entry Dialog
box appears.  It disregards the mouse actions and the arc is drawn to the
information entered in the Dialog box.  The arc radius and degree of length
can be set for a circular arc. The box shown below is for an Elliptical arc.

Elliptical Arc

When selecting the Elliptical arc button, the Dialog prompts the user to
type in the X, Y coordinates for the start and end-points for the arc.

Circular Arc

If the Circular arc button is selected, the End-Point Entry boxes change to
Radius, Start Angle, and Arc Angle.  When creating the circular arc, the
start point of the arc must first be set, and then the radius and degree of
length for the arc.

The Arc Tool Dialog box



Line Tool

The Line tool is designed to draw lines at any angle or length.  A line can
be drawn by clicking on the Line tool icon and positioning the cursor where
the line is to begin.  The cursor then becomes a crosshair showing the exact
position where the line begins or ends.  To draw perfect horizontal or
vertical lines, select the Line tool icon and hold down SHIFT when using
the tool.

Horizontal Lines Vertical Lines

When creating a line, drag the cursor in the direction the line is to be
created.  As long as the mouse button is held down, the line can be
lengthened or shortened and its angle can be changed.

Line Tool combined with Snap To Tools
The Line tool can be used with the Snap To tools, allowing the
user to start or end any line from another object center,
midpoint, end-point, percentage point, etc.  Remember that any
line can start or finish from any of the Snap To tools.  Use the
Tab key to change Snap To tools when dragging the mouse to
create lines.

For example, start the line from the end-point of another line
and finish the line at the center point of a circle, by changing
Snap To tools after setting the start point of the line.



Using Keyboard Entry with the Line Tool

The Line tool Numeric Keyboard Entry Dialog box can be accessed by
double clicking on the Line tool icon.  A Dialog box appears, allowing the
user to numerically enter the length, angle and start point.

After double clicking on the Line tool, the Numeric Keyboard Entry Dialog
box appears.  It disregards the mouse actions and the line is drawn to the
numeric information entered in the Dialog box.  The length and angle of the
line as well as the start point can be set.

When setting the start point, first select the Start Point button.  Notice that
the Dialog box information changes to coordinate positions.  These
coordinates allow the user to set the start and end-points of the line.  The
user can choose from Cartesian or Polar coordinates for drawing the line.
If the Polar coordinates are selected, a start point must still be set for the
line being drawn.

• Cartesian coordinates allow the user to set the start and
end-point at any X, Y coordinates.

• Polar coordinates allows the entry of the length and angle of
the line.  The start point coordinates must still be set for the
line being created.

Once the correct information is entered, click on the OK button to complete
the new line.

Click on the Cancel button to cancel the line drawing operation.



Spline Tool

The SHIFT key together with the Spline tool constrain each spline
segment to a perfect horizontal or vertical line.

The Spline tool is designed to draw Open or Closed free-formed splines,
that can contain many individual spline segments.  Choose the Spline tool
to create a curve that passes through specific points in the design.  The
points must be specified that KeyCAD Pro should use to draw the curve.
KeyCAD Pro then calculates the coordinates of the curve and draws the
free-formed curve.

A Closed Free-Formed Spline

A Open Free-Formed Spline

Spline Tool combined with Snap To Tools
The Spline tool can be used with the Snap To tools, therefore
allowing the user to start or end curved splines from another
object center, midpoint, end-point, percentage point, etc.
Remember that any open or closed spline can start or end from
any of the Snap To tools.  Use the Tab key to change Snap To
tools when dragging the mouse to create selected splines.

To use a Snap To tool with the Spline tool start point, first
select the required Snap To tool, then select the Spline tool
and place the start point.  To finish the Spline at a specific
Snap To tool, press the Tab key to change the Snap To tool
while drawing the spline, and double click at the desired end-
point.



Creating a Free-Formed Spline with the Mouse

To start drawing a free-formed spline, position the cursor on the first point
of the spline.  Click the mouse button and move the mouse, the mouse
button does not have to be held down.  A line follows the mouse movement.
Position the pointer on the next point that the curve should pass through and
click the mouse button again.  Another line begins from the previous point.
Continue moving the mouse and click to specify the number of points
required.

When the required number of points are specifed, double click the mouse
button.  KeyCAD Pro automatically draws the curved lines through the
selected points.

After  a spline is created, the tension value of the spline can be changed to
loosen or tighten the curves that pass through the points.  The Smoothing
pop-out menu is found under the Edit menu.  The Smooth, Unsmooth and
the Tension Dialog boxes can be selected from the pop-up menu.

The Smoothing pop-up menu

The Tension Dialog box



Using Keyboard Entry with the Spline Tool

When using the Spline tool there is the option of using numeric Keyboard
Entry, instead of the mouse.  To access the Dialog box, double click on the
Spline tool icon.

Within the Spline tool Dialog box, choose from Open or Closed splines and
set the start point of each spline and the number of points within the free-
formed spline.  Also choose from Cartesian or Polar coordinates.  The
Dialog box displays which point is being entered, as well as the total
number of points making up the spline.

After the point coordinates have been entered, press the Enter Point button,
to place and add the new point to the free-formed spline.  Continue adding
points as necessary.  Once the desired number of points are entered, click
on the End Spline button to automatically end the spline that is being
worked on.  KeyCAD Pro draws the curved lines through the points.  Click
the OK button to close the Dialog box.

The Spline Dialog box



The Dimension Tools

The Dimension tools are very important for drafting or creating
any type of blueprint.  The tools found within the Dimension
toolbox consist of Linear, Parallel, Angular, Diameter, Radius,
and Leader Line tools.

The Dimension toolbox can be turned On or Off and can be
relocated for faster access. The Dimension toolbox can be
accessed from the Tools pull-down menu found on the Menu
Bar.  It can also be turned On or Off from under the Window
menu using the Toolboxes pop-up menu.  A check mark
indicates whether the toolbox is On or Off.

The Tools pull-down menu

Combining Dimension Tools with Snap To Tools

Some of the Dimension tools can be used with the Snap To tools.  The
Dimension tools that work with the Snap To tools are Linear, Parallel,
Angular, and Leader Line.  The Diameter and Radius tools automatically
snap to the points of the object that have been dimensioned.



The following is a complete list of the Dimension tools found within the
toolbox.

Linear Tool

Parallel Tool

Angular Tool

Diameter Tool

Radius Tool

Leader Line Tool



Dimension Options

The dimensions that appear when using the dimension tools, have several
options available.  These options are designed to give the design a more
customised look.  The options available appear in the Dimensioning pop-
up menu  found under the Layout menu.  These options consist of Arrows
In, Arrows Out, Arrowheads choices, Center Text, Text Frame, Single
Tolerance, Double Tolerance, Limiting Tolerance, and the Tolerance
Values Dialog box.  The Tolerance Values Dialog is discussed in the
Layout Menu chapter under the Tolerance Values sub-chapter.

The Dimensioning options pop-up menu can be accessed under the Layout
menu.

Changing dimension colors

The color of any complete dimension including, text, arrowhead lines, and
witness lines can be changed.  First, select the dimension and its witness
lines and then choose a new color from the color picker.

Changing font size and style

Choose the font size and style from the Text menu before selecting the
required dimension tool.

The Dimensioning Options pop-up menu



Dimension Examples

The following examples display how the different options affect the
dimensions.

The Arrows In option

The Arrows Out option

The Text Frame option

The Single Tolerance option

The Double Tolerance option

The Limiting Tolerance option

1.770" 

0.946" 

1.472" 

1.770" ±0.500

1.770" +0.500
-0.500

2.270" 
1.270" 



Linear Dimension Tool

The Linear Dimension tool automatically calculates the correct distance
between any two points.  For example, lines, squares, rectangles, sides of
polygons as well as the distance between objects can be dimensioned.  The
Linear dimension tool is designed to display only horizontal dimensions
i.e., the horizontal distance between any two points.

NOTE: The examples above show a dimension that displays the actual
distance between any two points.  The Linear dimension tool snaps to any
of the Snap To tools.

1.986" 

1.444" 0.917" 

Linear dimension examples

Linear dimension between two objects



How to use the Linear Dimension Tool

1. Select the Linear tool from the Dimension toolbox.

2. Select the Snap To tool required to snap to the first point of
the object to be dimensioned.

3. Place the cursor near the point to start the dimension from.
Now click, hold down the mouse button and drag the cursor to
the second point of the dimension, and release the mouse
button near the point.

4. Now drag the dimension text out away from the object and
then click once to set the dimension distance.

When using the Snap To tools, dimensioning can be done from the end-
point of one object to the center point of another object.  A dimension can
start and end from any two combinations of the Snap To tools.

Remember that the Linear dimension tool always displays the dimension
perfectly horizontal.

Any of the dimension options can be applied within the Dimensioning pop-
up menu to any linear dimension.

 16'-0" 

Closet

Example of Linear Dimensioning



Parallel Dimension Tool

The Parallel dimension tool automatically calculates the dimension between
any two points and displays the correct distance between those points.  For
example, lines, squares, rectangles, sides of polygons as well as the
distance between objects can be dimensioned.  The Parallel tool is designed
to display only parallel dimensions i.e., the parallel offset of the actual
length between any two points.

Parallel dimension examples

Parallel dimension between two objects

NOTE: The examples above show the dimension that displays the actual
length between any two points.  The Parallel tool snaps to any of the Snap
To tools, allowing the user to start and end at different points of any two
objects.

1.581" 

1.414" 
1.000" 



How to use the Parallel Dimension Tool

1. Select the Parallel tool from the Dimension toolbox.

2. Select the required Snap To tool to snap to the first point of
the object to be dimensioned.

3. Place the cursor near the point to start the dimension from.
Now, click, hold down the mouse button and drag the cursor to
the second point, and release the mouse button near the point.

4. Now drag the dimension text out away from the object and
then click once to set the parallel dimension distance.

When using the Snap To tools, dimensioning can be done from the
midpoint of one object to the corner point of another object.  A dimension
can start and end from any two combinations of the Snap To tools.

Remember that the Parallel dimension tool always displays the dimension
perfectly parallel to the line or imaginary line between two objects.

Any of the dimension options can be applied within the Dimensioning pop-
up menu to any parallel dimension.

1.581" 

Imaginary line or
actual length between
the two center points



Angular Dimension Tool

The Angular dimension tool automatically calculates the angle between
two lines.  For example, triangles, angles of pentagons, sides of polygons
as well as the angle between objects can be dimensioned.  The Angular tool
is designed to display only angular dimensions between any two lines.

Angular dimension examples

Angular dimension between two objects

NOTE: The examples above show the dimension that displays the actual
angle between any two lines.  The Angle tool snaps to any of the Snap To
tools, allowing the user to start and end at different points of one or two
objects.



How to use the Angle Dimension Tool

1. Select the Angle tool from the Dimension toolbox.

2. Select the Snap To tool that is required to snap to the first
point of the angle to be dimensioned.

3. Place the cursor near the point from which to start the
dimension.  Now click, hold down the mouse button and drag
the cursor along the angled line, to the second point, and
release the mouse button near the point

4. Now drag the dimension text out away from the object, while in
a circular motion to reach any angle.  Then click once to set the
angled dimension distance.

Use the Snap To tools, to accurately snap to the end-points of the
angled line.

Click once at the
desired offset distance

Second Point

First Point



Diameter Dimension Tool

The Diameter dimension tool automatically calculates the dimension of
any circle's diameter and displays the correct diameter information of the
circle. This tool does not require the use of a Snap To tool.  The Diameter
tool automatically snaps to the circle boundary points.

Diameter dimension of a circle

NOTE: The examples above show the Diameter Dimension of a circle.
The Diameter tool automatically snaps the circle's boundary line, allowing
the user to quickly display the diameter of any circle.

1.319" 

1.319" 



How to use the Diameter Dimension Tool

1. Select the Diameter tool from the Dimension toolbox.

2. Place the cursor near the circle's boundary line.  Now click,
hold down the mouse button and drag the cursor in a circular
motion around the edge of the circle, and release the mouse
button near the point to be dimensioned.

3. Now drag the dimension text to any position on the dimension
line and release the mouse button.  The Dimension text
appears at the point where the mouse button was released.

Any of the dimension options can be applied within the Dimensioning pop-
up menu to any diametrical dimension.

Place cursor near
the circle

Drag the cursor to the
desired text position, and
release the mouse button



Radius Dimension Tool

The Radius dimension tool automatically calculates the dimension of any
arc radius, circle, or fillet and displays the correct radius information on the
screen.  The Radius tool is used only for dimensioning the radius of a 90
degree arc, radius of a circle, or the fillet of an object.  This tool does not
require the use of a Snap To tool.  The Radius tool automatically snaps to
the radius start point by clicking the mouse near the radius that is being
dimensioned.

Radius dimension of a Circle Radius of an Arc

Radius of a Fillet

NOTE: In the examples above the radius dimension display three different
types of radii.  The Radius tool automatically snaps the radius start point
allowing the user to quickly display the radius of any circle, fillet, or 90
degree arc.

0.514" 0.805" 

1.000" 



How to use the Radius Dimension Tool

1. Select the Radius tool from the Dimension toolbox.

2. Place the cursor near the radius boundary line.  Now click, hold
down the mouse button and drag the cursor in a circular
motion around the edge of the arc, circle, or fillet and release
the mouse button near the point to lock the radius dimension
to.  The Radius tool automatically snaps to the start point.

Place cursor near
the arc and hold down

the mouse button

Start Point
of Radius

3. Now drag the dimension text to any position on the dimension
line and release the mouse button. The Dimension text appears
at the point where the mouse button is released.

Any of the dimension options can be applied within the Dimensioning pop-
up menu to any radius dimension.  The font size, style or color can also be
changed.

Drag the cursor to the
desired text position,
and release the mouse

button



Leader Line Tool

The Leader Line tool is used for special quotes or parts of the design that
need a line with an arrow at the beginning of the line.

.500 radius typ.

Leader Line example

The Leader Line tool can be combined with the Snap To tools, so that the
user can snap to specific points of other objects.

How to use the Leader Line tool

1. Select the tool from the Dimension toolbox.

2. Now place the tool at the point from which to start.

3. Then click, hold down the mouse button, and drag the cursor
to a desired length.  Now release the mouse button and drag
the mouse to the end-point required, and click the mouse
button once.

The Leader Line tool has three points to be placed in order to create the
leader line.

1st Point
Start Point

2nd Point
3rd Point
End-Point

Creating A Leader Line



The Snap To Tools

Almost all technical and engineered drawings require the user
to draw lines, circles and rectangles in a very precise location,
in specific relationships to each other.  For example, to start a
line at the intersection of two different objects, or draw a line

        perpendicular to another line.  KeyCAD Pro provides the
Snap To tools to assist in locating the precise points required

in creating a very detailed and accurate design.

The Snap To toolbox has the option of being turned On or Off and
can be relocated for added convenience.  The Snap To toolbox
does not appear on the screen when the program is first started.
All toolboxes can be accessed under the Toolbox subheading
found under the Window menu at the top of the screen.  A check
mark beside the toolbox name indicates that it is active.

The Snap To tools have been designed to work in combination with the
Edit, Draw, and Dimension tools found within the program.  When using
the Snap To tools with the Draw tools a line can start from the end-point
of another line and finish at the center of a circle.  Using the Snap To tools
with other tools ensures that the line or object created starts and ends in the
precise location desired.

The sensitivity that determines how close the mouse cusor must be to an
object for the program to snap to a specific point can also be set.  The
sensitivity setting is found in the Preference Dialog under the Edit menu.



When using the Snap To tools, the tools selected can be
changed while dragging the mouse, by pressing the Tab key.
This is so that drawing or editing can start with one

     Snap To tool and end with another.

The following is a picture of the Snap To  tools as they appear in the
program.  The names have been listed for the appropriate tool icon.  The
name indicates the Snap To command that is performed when using that
particular tool.  These tools should be used in the precision alignment of
objects as well as with the start and/or end-points of objects.

NOTE: Remember, by combining these tools with the Draw, Dimensioning,
and Edit tools there is more precise control overall of the tools functions.

Drag Zone

Snap To  Toolbox

Close Button

Any Point

Center Point

Corner Point

Intersection Point

Point On

End-Point

Perpendicular

Line Center

Absolute Point

Percentage



Any Point

KeyCAD Pro defaults to the Any Point Snap To tool, when the program
is first started.  This allows the user to choose any point within the
document to set a point.  KeyCAD Pro supports an interactive snap to
function.  This means the ghost line of the object being drawn or edited
snaps to the selected tool's appropriate function, allowing the user to see
where the end-point is to be placed prior to releasing the mouse button. No
ghost lines are visible with the Any Point tool.

NOTE: If the Snap To Grid option is On, the user can only snap to points
on the current grid setting.  If the Snap To Grid option is turned Off, the user
can locate a point at any coordinate within the current document.

Changing Snap To Tools

When using the Any Point Snap To tool, the cursor always snaps to the point
on the screen, at the time the mouse button is clicked.

Setting Tool to Lock or Reset

The Any Point tool can be set to a locked position, so that it does not reset
after the first point is set.  Double clicking locks the tool to a dark
background and single clicking results in a gray background in the Reset
mode.

End-Point

Use the End-Point Snap To tool to connect the object being created to the
End-Point of another object.  The End-Point Snap To tool supports an
interactive snap to function.  This means the ghost line of the object being
drawn or edited snaps to the closest end-point, allowing the user to see
where the end-point is to be placed before releasing the mouse button.



When using the  End-Point Snap To command, first select the line to snap
to (line 1). With the handles at either end of the object, select the line tool
from the tool bar. Begin to draw your line (line 2) and you will notice that
it automatically gravitates to either one end or the other. If the line does not
snap to the ends raise the Snap Tool sensitivity in the  Edit, Preferences
dialog box. The Snap to line  command will work with any selected object
when the handle boxes are present.

n

Line  1

n

 Line 2

NOTE: If the Snap To Grid option is turned Off the user can then snap to
the closest end-point of the nearest object.  If the Snap To Grid option is On,
the user can only snap to points on the current grid setting.

Changing End-Point Snap To Tool

The Snap To tool can be changed at any time while pressing the Tab key.
This tool  allows the user to start with the End-Point tool, and end the object
with a different Snap To tool, such as the Center tool.



Setting End-Point Tool to Lock or Reset

The End-Point tool can be set to a locked position,to prevent resetting  after
the first point is set.  Double clicking locks the tool to a dark background
while a single click on the tool results in a gray background in the Reset
mode.

Point On

Use the Point On Snap To tool to connect the objects being drawn to a point
on another object.  The point the tool snaps to, is the closest calculated point
at the current position when the mouse button is released.  The Point On
Snap To tool supports an interactive snap to function.  This means the ghost
line of the object being drawn or edited snaps to the closest point within the
object, allowing the user to see where the point is to be placed before
releasing the mouse button.

Anytime the Point On  Snap To tool is selected, the cursor automatically
snaps to the closest point within the nearest object.  The tool snaps to any
point that is within the sensitivity range of the point.  Sensitivity can be set
in the Preference Dialog, found under the Edit menu.

NOTE: If the Snap To Grid option is On, the user can only snap to points
on the current grid setting.  If the Snap To Grid option is turned Off the user
can snap to the closest vertex point within the object nearest to the mouse
cursor.

Changing Snap To Tools

The Snap To tool can be changed at any time while pressing the Tab key.
This allows the user to start with the Point On  Snap To tool, and end with
a different Snap To tool, such as the End-Point Snap To tool.



Setting Tool to Lock or Reset

Set the Point On tool to a locked position, to prevent resetting after the first
point is set.  Double clicking Locks the tool to a dark background while a
single click sets the tool in a gray background in the Reset mode.

Center Point

Use the Center Point Snap To tool to connect the objects being drawn to the
center point of another object.  The tool snaps to the center point of the
closest object in relation to its current position, when the mouse button is
released.  The Center Point Snap To tool supports an interactive snap to
function.  This means the ghost line of the object being drawn or edited
snaps to the closest center point of an object, allowing the user to see where
the point is to be placed before releasing the mouse button.

Anytime the Center Point Snap To tool is selected the cursor automatically
snaps to the closest center point within the nearest object.  The tool snaps
to any center point of an object, if the cursor is within the sensitivity range
of the object.  Sensitivity can be set in the Preference Dialog, found under
the Edit menu.

NOTE: If the Snap To Grid option is On, the user can only snap to points
on the current grid setting.  If the Snap To Grid option is turned Off the user
can then snap to the closest point.

Changing Snap To Tools

The Center Point Snap To tool can be changed at any time while pressing
the Tab key.  This allows the user to start with the Center Point Snap To tool,
and end with a different Snap To tool, such as the Corner Point Snap To
tool.



Setting Tool to Lock or Reset

The Center Point tool can be set to a locked position, so that it does not reset
after the first point is set.  Double clicking locks the tool to a dark
background while a single click on the tool results in  a gray background
in the Reset mode.

Corner Point

Use the Corner Point Snap To tool to connect the objects being drawn to
the corner point on another object. Lines have two end-points that KeyCAD
Pro identifies as corner points.  The corners of other objects such as,
rectangles, arcs, circles, and ellipses, are at the corners of the rectangular
boundary lines.

The tool snaps to the corner point of the object which is closest to the
current position at the moment the mouse button is released.  The Corner
Point Snap To tool supports an interactive snap to function.  This means the
ghost line of the object being drawn or edited snaps to the closest corner
point of an object, allowing the user to see where the point will be placed
before releasing the mouse button.

When the Corner Point  Snap To tool is selected the cursor automatically
snaps to the closest corner point within the nearest object.  The tool snaps
to any corner point of an object, if the cursor is within the sensitivity range
of the object.  Sensitivity can be set in the Preference Dialog found under
the Edit menu.

Corner point
of a circle

Corner
point of a rectangle



NOTE: If the Snap To Grid option is On, the user can only snap to points
on the current grid setting.  If the Snap To Grid option is turned Off the user
can then snap to the corner point within the object closest to the cursor.

Changing The Corner Point Snap To Tool

The Corner Point Snap To tool can be changed at any time by pressing the
Tab key.  This allows the user to start with the Corner Point Snap To tool,
and end with a different Snap To tool, such as the Perpendicular Point Snap
To tool.

Setting Tool to Lock or Reset

The Center Point tool can be set to a locked position, so that it does not reset
after the first point is set.  Double clicking locks the tool to a dark
background while a single click on the tool results in a gray background in
the Reset mode.

Intersection

The Intersection Snap To tool should be used to connect the start or end-
point of an object where two other objects intersect.  An intersection is
defined as any point where the lines of two objects meet or cross.

Intersection point

Intersection point



When using the Intersection tool, the user can snap to any intersection point
of two objects.

The Intersection Snap To tool supports an interactive snap to function.  This
means the ghost line of the object being drawn or edited snaps to the closest
intersection of any two objects, allowing the user to see which intersection
the point is to be snapped to before releasing the mouse button.

The Intersection tool snaps to the intersection point of any two objects, if
the cursor is within the sensitivity range of the intersection.  Sensitivity can
be set in the Preference Dialog found under the Edit menu.

NOTE: If the Snap To Grid option is On, the user can only snap to the
closest points on the current grid setting.  If the Snap To Grid option is
turned Off the user can then snap to any intersection point of two objects.

Perpendicular

This tool should be used when a line is to be automatically drawn
perpendicular to other objects within a design.

The following examples show lines drawn perpendicular to other types of
objects.

Rectangle Open or Closed Polygons



To draw a line perpendicular to an object.

1. Select the Line tool from the Draw toolbox.

2. Then, select the Perpendicular Snap To tool.

3. Now, place the mouse cursor near the object that the line is to be
perpendicular to, click and drag the mouse to the desired line
length and release the mouse button.

The user can also designate that a line be perpendicular to an object at it's
end point.  As the line is being drawn to the object it is to be perpendicular
to, before releasing the mouse button make sure the  Perpendicular tool is
selected.  Now when the mouse button is released near the object, the end-
point of the line becomes perpendicular to the object.

NOTE: If the Snap To Grid option is On, the user can only snap to points
on the current grid setting. If the Snap To Grid option is turned Off the user
can then have lines snap perpendicular to other objects at any position.

Changing the Perpendicular Snap To Tool

The Perpendicular Snap To tool can be set at any time after drawing a line
has started, by pressing the Tab key.

Line Circle



Setting Tool to Lock or Reset

The Perpendicular tool can be set to a locked position, so that it does not
reset after the first point is set.  Double clicking locks the tool to a dark
background while a single click on the tool results in a gray background in
the Reset mode.

Line Center

The Line Center tool automatically sets the start or end-point of a line at the
exact midpoint of a line or free-formed spline.

The following examples further explain how one object may have more
than one mid-point.  This means that the Line Center tool snaps to any
midpoint within an object.

To draw a line at another object midpoint, first select the Line tool from the
Draw toolbox and then select the Line Center tool.  Now place the mouse
cursor near the object to snap to.  Click and drag the mouse away from the
object, and the line start point automatically snaps to the line center point
of the object.  Remember that the line center is located between any two
points with a line between them.  The line can be straight or curved.

Midpoint
Midpoint

Midpoint
Midpoint

Midpoint

Midpoint



The user can also designate the end-point of the line being drawn, to finish
at the line center point of another object.  As the line is being drawn to set
its end-point, be sure that the Line Center Snap To tool is selected, before
releasing the mouse button.  Now, when the mouse cursor is near the object
to set the end-point at, release the mouse button.  KeyCAD Pro automatically
snaps the end-point of the line to the line center point.

The Line Center Snap To tool supports an interactive snap to function.  This
means the ghost line of the object being drawn or edited snaps to the closest
line center point.  Therefore allowing the user to see where the line center
will be placed before releasing the mouse button.

NOTE: If the Snap To Grid option is On, the user can only snap to points
on the current grid setting.  If the Snap To Grid option is turned Off the user
can then have lines snap to line center points of other objects.

Changing The Line Center Snap To Tool

The Line Center Snap To tool can be changed at any time after drawing a
line has started, by pressing the Tab key.

Setting Tool to Lock or Reset

The Line Center tool can be set to a locked position, so that it does not reset
after the first point is set.  Double clicking locks the tool to a dark
background while a single click on the tool results in a gray background in
the Reset mode.



Percentage

This tool allows the user to locate a point on a line, arc, or polygon by
specifying a percentage value of the line.  The percentage indicates a
distance along the length of the line. The start point is considered 0% and
the end-point is 100%. A point located at 40% of the line's length can be
specified and KeyCAD Pro automatically locates that point.

0% 25% 50% 75% 100%

The percentage snap value can be set in the Preference Dialog, which is
found under the Edit menu.

To draw a line starting at a percentage point of another line, first select the
line tool from the Draw toolbox.  Then select the Percentage Snap To tool,
place the mouse cursor near the line to snap the start point to, and click and
drag the mouse away from the line.  KeyCAD Pro automatically snaps the
start point, to the percentage snap point of the line selected.

The previous paragraph explained how to snap the start point of a line.  The
same principle applies to the end-point of the line being created.  As the line
is being dragged, change the Snap To tool to the Percentage tool.  Then
position the end-point of the line, near the line to snap to and release the
mouse button.

Start Point End-Point



The Percentage Snap To tool supports an interactive snap to function.  This
means the ghost line of the object being drawn or edited snaps to the closest
percentage point.  This allows the user to see where the percentage point
is placed before releasing the mouse button.

NOTE: If the Snap To Grid is On, the user can only snap to points on the
current grid setting.  If the Snap To Grid option is turned Off, the user can
then have lines snap to any percentage point that have been set for the
percentage tool.

Changing The Percentage Snap To Tool

The Percentage Snap To tool can be changed at any time after starting to
draw a line, by pressing the Tab key.

Setting Tool to Lock or Reset

The Percentage tool can be set to a locked position, so that it does not reset
after the first point is set. Double clicking locks the tool to a dark
background while a single click on the tool results in a gray background in
the Reset mode.

Sensitivity Settings

The Percentage tool snaps to any percentage point of any line, if the cursor
is within the sensitivity range of the percentage point.  Sensitivity Snap To
setting can be found in the Preference Dialog, which is found under the
Edit menu.



Absolute Point

The Absolute Point tool always snaps objects, start or end-points of objects
to the Absolute point of a design.  The absolute point is the same as the point
where the X, Y - Axis lines meet; it can also be referred to as the Origin
point.  The absolute point is always equal to X - 0 and Y - 0.  This is the
reference point for all absolute readouts.  The absolute point is located at
the lower left corner of a design when the program is started.

The absolute point is a great point of rotation.  It is used for rotating and
duplicating objects simultaneously, thus providing a point of rotation that
can be located at any point within a design.  This is because the Axis Lines
can be moved to any location.

The Absolute Point Snap To tool supports an interactive snap to function.
This means the ghost line of the object being drawn or edited snaps to the
current absolute point within the document, allowing the user to see where
the end-point of the drawn line is to be placed before release of the mouse
button.

To draw a line from the absolute point, first select the Line tool from the
Draw toolbox.  Then select the Absolute Snap To tool and place the mouse
cursor near the absolute point on the document.  By clicking and dragging
the mouse, the start point of the line automatically snaps to the absolute
point.

Rotate objects around
the Absolute Point (Origin Point)



The end-point of the line being drawn can be designated, to finish at the
absolute point within the document.  As the line is being drawn to set its
end-point, be sure that the Absolute Point Snap To tool is selected, before
releasing the mouse button.  Now, when the mouse cursor is near the
absolute point in the document, release the mouse button.  KeyCAD Pro
automatically snaps the end-point of the line to the absolute point.

Changing The Absolute Snap To Tool

The Absolute Point Snap To tool can be changed at any time after starting
to draw a line or moving an object, by pressing the Tab key.

Setting the Absolute Point Tool to Lock or Reset

The Absolute Point tool can be set to a locked position, so that it does not
reset after the first point is set.  Double clicking locks the tool to a dark
background while a single click on the tool results in a gray background in
the Reset mode.

Sensitivity Settings

The Absolute Point tool snaps to any absolute point coordinate that is
currently set within the document, if the cursor is within the sensitivity
range of the absolute point.  Sensitivity of Snap To settings can be found
in the Preference Dialog under the Edit menu.



The File Menu

The File menu contains the commands which control the opening and
closing of files and symbols.  Printing of drawings is also controlled from
within the File menu.

Some of the File menu commands can be accessed with keyboard
equivalents, when combining the CTRL key (COMMAND key on the
Macintosh) with the appropriate key, as shown below.  The following
pages in this chapter explain the proper uses for these menu commands.

The File Menu



New

The New command is used to open a new document as shown below.  The
new document is untitled and has only one layer.  The title bar automatically
displays Untitled, which means that the document has no name.  To name
the document, save the document.

KeyCAD Pro supports multiple documents, meaning that the New
command can be used even if another document is already  open.  The new
documents appear on top of each other, without replacing the previous
document.  In order to change the names of the new documents, save them.

Open...

This command is used to open previously created documents. To access
this command select the Open command from the File menu, or press
CTRL+ O (COMMAND+O for Macintosh). After choosing the Open
command, a Dialog appears allowing the user to select the name of the file
to be opened.

The Open Dialog box (Macintosh)



On the appearance of the Dialog box select the required document from
the list in the left hand box.  The list contains the names of each KeyCAD
Pro file.  The directories on the current drive are shown in the right hand
box.  If there are more filenames than can fit in the window, use the scroll
bars to find the file or directory name required.

Click the Cancel button to return to the screen before the Open command
was selected.  Refer to the Windows User Manual under Opening
Documents.

Close

The Close command is used to close the currently active document.  The
Close command is found under the File menu or press CTRL+W
(COMMAND+W for Macintosh) to activate the Close command.

Other open documents are not affected by the Close command.  To close
a window that is not active, click on the window first to activate it and then
choose the Close command.

If changes have been made to a currently active document since the last
time it was saved, a message Dialog appears asking if the user wants to save
the changes before closing the window or document.

The Open Dialog box (Windows)



Save

This command saves a copy of the current document being worked on.
The Save command is found under the File menu, or it can be accessed
by pressing CTRL+S (COMMAND+S for Macintosh).

When choosing the Save command, only the document that is active is
saved.  The program always saves the file to the currently selected
directory or drive.  If there are several windows open, activate the window
that contains the document to be saved, before selecting the Save
command.

In the case of an untitled document, a Dialog box appears requesting a  file
name.

Enter a name for the drawing and either click the OK button or press
ENTER.  If the current disk does not have sufficient free space, a
message appears asking to save the document to another disk.

If the document already has a name, the Dialog box is not displayed. The
Save command automatically updates the current document by replacing
the version on the disk with the version currently active on the screen.

The Save Dialog box (Windows)



Save As...

To update the most recent changes of the current document, choose the
Save command.  Use Save As to save a copy of the current document to a
second file without affecting or replacing the version currently held on
disk.

The Save As command saves a file or document under a different name,
directory, or to a different disk drive. Save As can be used to save a new
document for the first time. The Save As command is found under the File
menu.

The Save As Dialog box (Macintosh)

The Save As command can be used in different ways.  For example, to
make a backup copy of a current work file, or keep both the original
version of the file along with a more recent  version.  In making different
versions, save the original version under one name, and then use Save As
again to save the new document under a different name.

To save a file in a different directory, double click the directory name in
the Directories box to open the new directory. Change which drive the new
file is saved to, by clicking on the drive name shown in the lower right-hand
corner of the Save As Dialog box.



Import

The Import option is a pop-up menu that is used to access the different file
formats that are supported within KeyCAD Pro.  The formats that can be
imported are DXF (AutoCAD), DRW, CorelDraw, PICT, and XYZ
Coordinates.

PICT (Macintosh only)

Choose PICT to import files that have been saved in the PICT format.  This
is a standard graphics file format used on the Macintosh.  These files are
primarily used in painting programs.

DRW (Windows only)

Choose DRW to display or open files that have been saved in the DRW
format.  DRW is the Micrographix Designer file format.

DXF

Choose DXF to display or open files that have been saved in the DXF
format.  The DXF format is the most popular among AutoCAD users, this
format is used when transferring AutoCAD files from one computer
program to another.

NB: Versions of AutoCAD DXF subsequent to Version 10   are not
supported.

Windows                                                              Macintosh



XYZ Coordinates

This format is used to import XYZ coordinate points.  When using this
format, the program only places data points in the proper coordinate
position.  The program does not draw lines or curves between these points.

CorelDraw... (Windows only)

Choose CorelDraw... to display or open files that have been saved in the
CDR file format. CDR is the CorelDRAW file format. This version of
KeyCAD Pro supports file formats from CorelDRAW version 3.0 or
lower.

As the warning in the dialog box indicates, some fill patterns used in
CorelDRAW are not able to be converted.

There are two ways to import a CDR file, Picture and Vector, and they are
described below.

Picture format

The file will be displayed on the screen as one scaleable object.  You cannot
edit the individual shapes and objects that were in the file.  You can resize
the entire picture just as you would any other object.  This is the default
CDR import format.

The Corel Draw Dialog Box



Vector format

To use this method, click on the radio button to the left of CorelDRAW
(Vector).  If this method is used, the individual objects that make up the
drawing can be edited and resized.

After selection of  the appropriate method, and click on the OK button, you
will then be presented with the standard open dialog box to locate the file.

BMP (Windows only)

Choose BMP to display or open files that have been saved in the BMP
format.  This is a standard graphics file format used in Windows.  BMP files
are bitmap or raster files.  These files are primarily used in painting
programs.

EPS (Preview) (Windows only)

Choose EPS to display or open files that have been saved in the EPS
format.  The EPS format stands for Encapsulated PostScript, which
translates a file to the PostScript page-command language.  This format
is very popular among page layout and illustration programs.

TIFF (TIF) (Windows only)

Choose TIFF to display or open files that have been saved in the TIFF
format.  The TIFF (Tagged Image File Format) file format is used to save
scanned images.



Export

The Export option is a pop-up menu that is used to access the different file
formats that are supported within KeyCAD Pro.  These formats can be
used to export to any program that supports the DXF, HPGL, EPS, and
XYZ Coordinates.  When one of the formats within the Export menu is
selected, a Dialog box appears prompting the user to name the file.

                                       

                  Windows     Macintosh

PICT (Macintosh only)

Choose PICT to export or save files in the PICT format.  This is a standard
graphics file format used on the Macintosh.  These files are primarily used
in painting programs.

DXF

Choose DXF to export or save files in the DXF format.  The DXF format
is the most popular among AutoCAD users, this format is used when
transferring AutoCAD files from one computer program to another.

HPGL

This format is exported to create an HPGL file that can be used with plotter
servers.  A file can be plotted without having to have the KeyCAD Pro
program running when plotting.



EPS

The EPS format stands for Encapsulated PostScript, which translates a
file to the PostScript page-command language.  This format is very
popular among page layout and illustration programs.

XYZ Coordinates

This format is used to export XYZ coordinate points.  When using this
format, the program only places data points in the proper coordinate
position.  The program does not draw lines or curves between these points.

Open Symbol...

Symbols are treated like individual files that can be placed within the
current design.  Symbols are predrawn images that can be used to save
time when creating a design.

Remember that a Symbol file format is different from the regular file
format that the designs are saved in when the user selects the Save or Save
As command. Symbol files have the extension .SYM.

The Open Symbol Dialog Box (Windows)



The Open Symbol Dialog Box (Macintosh)

Opening a symbol (Macintosh)
1. Pull down the File menu and select the Open Symbol command.

A Dialog box, like the one above, will appear.
2. Select the desired disk drive.
3. Select the desired directory.
4. Select the desired Symbol (or KeyCAD) file by using the scroll

box.
6. Click on the Open button.  The symbol will be centered in the

current view window.



Opening a symbol (Windows)
1. Pull down the File menu and select the Open Symbol command.

A Dialog box will appear.
2. Select the desired disk drive by using the scroll box under the

Drives heading.
3. Select the desired directory by using the scroll box under the

Directories heading.
4. Select the desired file fomat, .SYM or .KEY from the List Files

of Type heading.  If the .KEY file format is used, the .KEY file
will be read in and placed as a symbol.

5. Select the desired Symbol (or KeyCAD) file by using the scroll
box under the Symbol Name heading.

6. Click on the Place button.  The symbol will be centered in the
current view window.

Show Preview

The Show Preview check box can be either turned On or Off.  An X in the
box indicates that Show Preview is turned On.  If this option is on, a scaled
version of the symbol is shown in the preview box on the left of the screen.
If this option is turned Off, then no image appears in the preview box.

Save Symbol...

When an object has been created and it is to be saved as a Symbol, first
select the object to be saved, before choosing the Save Symbol command.
A fter selecting the Save Symbol command from the File menu, a Dialog
box appears prompting for the name of the symbol.  After the symbol has
been saved, the symbol can be opened again from the Open Symbol
command.  All symbols are given the extension .SYM in order that they
can be easily identified.

Send Mail... (Windows only)

See Microsoft Windows 95 user manual.



Paper Size...

When the Paper Size command is selected from the File menu, a Dialog
box appears asking the user to choose the paper size for the new document.
There are several industry standards to choose from, or the option to create
a custom paper size.  The program also supports most of the metric
standard sizes of paper.  The pull-down menus have the letter or numeric
name along with the paper’s actual dimension size.  When the program
is first started, it defaults to the Mechanical “A” size (8.5"x11") piece of
paper.  The Paper Size can be changed at anytime while creating the
design.  Click the OK button after selecting the appropriate paper size.

The program represents the paper with a white background.  Scroll to the
edge of the paper and notice where the paper ends and the background
color of the monitor begins.

Below is an example of the Paper Size Dialog box, and the following pages
display the pull-down menu options.

The Paper Size Dialog Box



The Paper Size Chart

Architectural: A 9" x 12"
B 12" x 18"
C 18" x 24"
D 24" x 36"
E 36" x 48"
F 28" x 40"
30/42 30" x 42"

Mechanical: A 8.5" x 11"
B 11" x 17"
C 17" x 22"
D 22" x 34"
E 34" x 44"

Metric: DIN A4 210mm x 297mm
DIN A3 297mm x 420mm
DIN A2 420mm x 594mm
DIN A1 594mm x 841mm
DIN A0 841mm x 1189mm
DIN B1 707mm x 1000mm

Metric Oversize: A4 240mm x 330mm
A3 330mm x 450mm
A2 450mm x 625mm
A1 625mm x 880mm
AO 880mm x 1230mm

Custom Size... Can choose from in., mm or cm and have custom
horizontal width and vertical height paper
dimensions.



Page Setup Command (Windows)

Page Setup...

The Page Setup command specifies the paper size, orientation, and
pagination of the current file when printing the active file.  The Page
Setup command is found under the File menu.  After choosing the Page
Setup command, the Print Setup Dialog box appears on screen.

Page Setup Command (Macintosh)



Print/Plot... (Macintosh Only)

The Print/Plot command can be selected from the File menu or by
pressing Command+P.  The program prints only the active view on the
screen. Any other documents or files in the background that are opened
are not printed.

NOTE: The information which is displayed in the Print/Plot Dialog box
depends on the system software and printer drivers that are in use.

The following example displays and discusses the Print/Plot Dialog box
for a Hewlett Packard printer.  The settings and choices within the Dialog
box vary for different printers.  Refer to the Printer or Plotter Manual for
more details concerning the printing device.

Print/Plot Dialog Box



The Plot Dialog Box

Plot... (Windows Only)

The Plot command is used to plot designs to any HPGL (Hewlett Packard)
compatible plotter.  The Plot Dialog box is used to set the program's
parameters to the plotters specification.  For plotter specifications refer to
the Plotters Manual.

There is the option to set the Baud Rate, Stop Bits, Parity, Data Bits, and
a choice of several different HP plotter models.

Before clicking on the Plot button, be sure that the Dialog box settings are
set for the plotter.



Print (Windows Only)

The Print command can be selected from the File menu or by pressing
CTRL+P (COMMAND+P for Macintosh).  The program prints only the
active view on the screen. Any other documents or files in the background
that are opened are not printed.

NOTE: The information which is displayed in the Print Dialog box
depends on the system software and printer drivers that are in use.

The following example displays and discusses the Print Dialog box for an
Epson printer.  The settings and choices within the Dialog box vary for
different printers.  Refer to the Printer or Plotter Manual for more details
concerning the printing device.

Exit

The Exit command is used to exit the KeyCAD Pro program.  Choose the
Exit command from the File menu or by pressing CTRL Q.

If any changes are made to the currently opened file, the warning  "Save
changes before closing?" appears.  Respond appropriately.  In the case of
untitled files, the Save As Dialog box is displayed which prompts the user
to enter a name for the file.

Print Dialog Box



The Edit Menu

The Edit menu is designed to offer the commands for changing, editing or
modifying any object and text within a design.  Many of these commands
have menu equivalents for quicker access.

The Preferences Dialog box is accessed under the Edit menu. This is where
the preference of certain defaults found within the program can be changed.
Some of the Menu Bar button selections are also found under the Edit menu.

Some of the File menu commands can be accessed with keyboard equivalents,
when combining the CTRL key (COMMAND key on the Macintosh) with
the appropriate key, as shown below.

The Edit Menu



Show Clipboard

An additional command is located under the Edit menu in KeyCAD Pro
for Macintosh, Show Clipboard. This command will display the current
contents of the Clipboard.

Undo

The Undo command is used to cancel the last action that changed the file
being worked on.  For example, if a door is created then resized, to revert
to the original size, choose the Undo command from the Edit menu.

The Undo command permits cancellation of the last action on an object,
such as duplicating, resizing, reshaping or changing position and location.

NOTE: Undo works only on the last action performed.  Once another
action changes the file, the preceding action cannot be undone.

Scrolling, selecting a drawing, changing of a Dialog box, or the resizing of
a window, are actions that cannot be undone and effectively do not change
a file.

There are two ways to activate the Undo command.  Select Undo from the
Edit menu or press CTRL Z.

Undo is found under the Edit Menu



Cut

The Cut command removes any selected objects or text from the design and
automatically places them on the Clipboard.  Remember that when the Cut
command is used, anything currently on the Clipboard is replaced with the
new selection that was Cut.

The Cut command can be selected from the Edit menu or by pressing
CTRL+X.

Cut is found under the Edit Menu

Use Cut to delete objects or text, or to move them to a new location on the
design.  To use the Cut command first select the object or text and choose
the Cut command; it cuts the selected objects to the Clipboard.  Move or
scroll the document  to a new location and choose the Paste command to
place the Clipboard contents at the center of the new location.  The Paste
command is also found under the Edit menu.

Cut can be used to move objects from one KeyCAD Pro document to
another.  Cut the object from the first document, then open the second
document and choose the Paste command.  If there are multiple windows
opened, the user can Cut from the active window then click on the target
window to activate it, then choose the Paste command.

Copy

Choose the Copy command to copy selected objects or text to the Clipboard.
The copied object replaces anything previously on the Clipboard.  Use the
Copy command to duplicate objects or text within the current document or
different files.



The Copy command can be selected from the Edit menu, or by pressing
CTRL+C.

Objects or text must be selected prior to selecting the Copy command.  After
selecting the Copy command, the objects or text remain selected.  Deselection
is done by clicking anywhere on the drawing area.

Once a selection is copied to the Clipboard, the object or text can be pasted
to another section of the document or even to the file of another application
that supports the Paste command.

Paste

The Paste command places a current copy of the Clipboard contents into
the active layer of the current window.  Pasting an object from the Clipboard
does not clear the Clipboard contents.  Because the contents of the
Clipboard remain on the Clipboard, the Paste command can be used
repeatedly to make multiple copies of text or objects within the same or
different files.  For a description on other methods of duplicating objects,
refer to Duplicate and Duplicate offsets later in this chapter.

Copy is found under the Edit  Menu



Paste can be selected from the Edit menu, or by pressing CTRL+V.

Paste is found under the Edit Menu

Pasting an Object

KeyCAD Pro pastes an object by placing it in front of all other objects within
the current file.

• If the current file has just been opened and the Paste command
selected, the copy is placed in the center of the screen.

• If the file in the window has been scrolled, the copy is placed in
the center of the screen.

• Since KeyCAD Pro supports multiple layers within one file, the
Cut, Copy, and Paste commands can also be used when moving
objects between layers.

• Be sure to activate the layer first before choosing the Copy
command, then activate the layer to Paste the object into.

Transferring Pasted Objects

An option exists for the transferring of complete drawings, individual
objects, and text created in other applications.  The files designed in  other
Draw or CAD programs, can be transferred to the Clipboard, and then



pasted into KeyCAD Pro documents.  The entire contents of the Clipboard,
are pasted into the KeyCAD Pro document as one object and not separately.
Once the object has been pasted within the document, resizing of the object
can be performed.

NOTE: To paste a drawing, object or text from any kind of Paint product,
remember the applications draw the images on pixel basis dot by dot
(bitmapped).  The user cannot edit the objects that appear within the
boundaries of the pasted object.  These objects cannot be Ungrouped or
Unjoined.  Files created in a Paint application are called Raster files.

If Cut, Copy, and Paste are used to transfer objects from applications that
support vector objects such as KeyCAD Pro, the user can edit, ungroup,
or unjoin these objects.  Files created in a draw application are called Vector
files.

Clear

The Clear command removes (clears) selected objects or text from the
design.  The Clear command does not place the cleared object on the
Clipboard.  Clear is used to delete or permanently remove any selected
object or text.  This is useful to clear an object from the design, while
maintaining the contents of the Clipboard.  The DEL key functions in the
same manner as the Clear command.

NOTE: The Undo command may be used to cancel the most recent
operation.

How to Clear an Object
1. Select the object or text to be cleared.
2. Pull down the Edit menu and select Clear or press DEL.
3. The object selected is removed from the design.  If necessary Undo

can be used to retrieve the object.



Select All

The Select All command allows for the selection of all the objects within the
current design including text and geometric shapes.  The vertex points of
each object are highlighted indicating that all the objects are selected.

Upon choosing the objects within the design, it is easy to move them to a
different location.

Moving objects with Select All

1. Pull down the Edit menu and choose the Select All command or
press CTRL A.  Notice that all the vertex points are highlighted.

2. Click on the Selection tool (Arrow tool), from the Edit toolbox.
3. Place the cursor on top of one of the selected objects and hold

down the mouse button while dragging the objects to a new
position.  Watch the readouts at the bottom of the screen for a
precise location.

Another use of the Select All command, is to select all objects before
choosing a command that affects the entire file.  For example, all the
objects within the design can be locked to a specific grid point, or even
group all of the objects together.  To clear everything from the design,
choose the Select All command, and press DEL, or select Clear from the Edit
menu.  This is easier than selecting each individual object.

Using Select All to Move Objects

With the Select All command subsequent mouse repositioning moves all
the objects together.  Individual objects cannot be repositioned but the
place of the entire design can be changed by dragging the objects to a new
location.  If the entire design is bigger than the monitor, choose Fit to
Window to assist in design adjustment.



Resizing with Select All

Once the Select All command is chosen, each individual object cannot be
resized.  If a handle is dragged, it proportionally and simultaneously resizes
all of the selected objects.  For example, if a handle is dragged to reduce the
size of one object, all selected objects are reduced by the corresponding
amount that the mouse is dragged.  However, the relative distance between
all objects does not change.  The proportional distance from the center of
one object to the center of the next object remains the same.  Only the object
size changes either by enlargment or reduction.  Objects can be reduced by
pushing the mouse towards the center of an object and enlarged by
dragging it away.

An entire design can be reduced or enlarged yet maintaining proportional
spacing between objects.  First, select the Select All command from the
Edit menu, and then choose the Group command found under the Options
menu.  Then select the Resize tool and grab a selected handle, and begin
reducing or enlarging.  An example for this option is to reduce the entire
size of a design to fit on a particular size of paper.

Detect All

The Detect All command should not be confused with the Select All
command.  These two commands have completely different end results.
The Detect All command can be accessed under the Edit menu, or by
pressing CTRL K.

Detect All is designed to undo the Hide Selection command also found
under the Edit menu.  The Hide Selection command hides any selected
objects from being selected again.  To select an object which is currently
hidden use the Detect All command.

Example
• First, select one or more objects, and then select the Hide Selection

command from the Edit menu; the chosen objects cannot be now
selected.

• To deactivate Hide Selection choose Detect All from the Edit
menu.



This feature is useful when working in very detailed design areas and
problems are encountered selecting a particular point due to the close
proximity of several points.

Hide Selection

The Hide Selection command is used to select any object or groups of
objects such as lines, rectangles, circles, polygons, and hide them to
prevent selection with any of the tools.

Example
1. Select the objects to be hidden using the Selection tool from the

Edit toolbox.
2. Now, pull down the Edit menu or press  CTRL J to activate the Hide

Selection command.
• To release the Hide Selection command, select Detect All from the

Edit menu or press CTRL K.

This feature is useful when working in very tight design areas and problems
are encountered selecting a particular point due to the close proximity of
several points.

Duplicate

The Duplicate command immediately copies any and all selected objects,
including text blocks.  The duplicate objects are placed in the current
window.  This command does not place a copy of the selected objects onto
the Clipboard, therefore the Paste command is not necessary.  Duplicate
is an option that allows copies of any selected object in one step.

The Duplicate command is found under the Edit menu, or press CTRL D.

The Duplicate Offsets affect the location of the newly duplicated objects.
Refer to the upcoming section called Duplicate Offsets, for more information.



Using Duplicate

When using the Duplicate command, first select the object(s) to duplicate.
Then, pull down the Edit menu and select the Duplicate option, or press
CTRL D.  The copy that appears is slightly offset from the original.  Once
the object is selected, it can be edited, reduplicated or relocated.

If objects that appear on different layers are selected and duplicated, the
duplicates appear on the same layers as the original objects. To duplicate
an object and place it on a different layer, use the Cut, Copy and Paste
commands.  This copies the object and places it on the Clipboard.  Pasted
objects appear in the active layer.

Example

The example below shows the duplication of a  bush for a landscape layout.

1. Select the bush as shown below.  Notice the highlighted points
around the object.

Sidewalk

Highlighted Points

Porch



2. Now pull down the Edit menu and select Duplicate, or press CTRL
D.  After selecting Duplicate, notice the new object is highlighted.
Use the Selection tool to drag the duplicate to a new location.

        Porch

Sidewalk

Duplicate Bush

3. After moving the second duplicate bush, select the Duplicate
command and make a third bush.  Reposition the third bush to its
proper location.

Sidewalk

 Porch

Third Bush



4. When moving the objects after duplication monitor the readouts
at the bottom of the screen to assist in relocating the selected
object to a precise coordinate.

NOTE: The Duplicate Offsets Dialog box determines the offset distance of
the duplicate object(s). The Duplicate Offsets Dialog box can be accessed
from the Edit menu.

Duplicate Offsets...

The Duplicate Offsets Dialog box is useful for laying out charts and other
design elements such as evenly spaced bolt patterns or multiple shrubs in
a landscape design.  The Duplicate Offsets Dialog function duplicates a
selected object requiring a number of evenly spaced copies.

The Duplicate Offsets Dialog can be accessed by pulling down the Edit
menu.  After typing the Horizontal and Vertical offsets together with the
number of Repeats, click the OK button or press ENTER  to close the Dialog.

The Horizontal or Vertical offsets are changed  within the Duplicate Offsets
Dialog box.  The Duplicate command duplicates the number of objects and
their offsets in correlation to the settings within the Duplicate Offsets
Dialog box.

All Duplicate Offset objects are measured from the origin of the preceding
object.  Once the Duplicate Offsets and Repeat Count of a selected object
is chosen, the position of the first copy is measured from the origin of the
original object.  The position of the second copy is measured from the
origin of the first duplicate copy.  This process is repeated as many times
as the Repeat Count entry displays.

Copies of objects created via the Duplicate Offsets or Duplicate command
are placed in front of the original.  This applies to each duplicated object
regardless of the Repeat Count number.



NOTE: The Duplicate Offsets and Duplicate command do not affect the
contents of the Clipboard.

The example below shows the actual Duplicate Offsets Dialog box settings
found within the program.

The Duplicate Offsets Dialog box

How to use the Duplicate Offsets
1. First, select the object to be duplicated by using the Duplicate

Offsets Dialog box.

The Selected object

2. After selecting the object, pull down the Edit menu and select
Duplicate Offsets.  After the Dialog box appears type in a Horizontal
Offset of 1.00" and a Vertical Offset of  0", and a Repeat Count of
2.

3. Now click the OK button or press ENTER



 The design repeats as shown below.

The Objects after a Duplicate Offset command

Mirror Horizontal

The Mirror Horizontal command is used to flip any selected object or group
of objects in a diametrically different direction.  Select an object and perform
the Mirror command to make a duplicate of the object flipped horizontally
and placed by a certain offset.

The Mirror Horizontal command is found under the Edit menu.  For quick
access to the Mirror Horizontal command, activate the Menu Bar and click
the Mirror button

.

The Menu Bar can be turned On or Off by pressing CTRL M or by pulling
down the Layout Menu and selecting Menu Bar.

How to use Mirror Horizontal

The following example shows how to use the Mirror command to create a
frontal view of a tree.  Creation of the first half of the tree is devised using
the Open Polygon tool.

1. First select the object or group of objects to mirror.  Use the
Selection tool for selecting objects.

2. Once the object is selected, pull down the Edit menu and select
Mirror Horizontal, or press the Mirror button on the Menu Bar.

Mirror Button



3. Notice that after the Mirror command is selected, the newly
duplicated copy is selected and slightly offset in the Horizontal
axis.  This is so the object can be moved or edited if necessary.

4. Now that the second half of the tree is created, use the Selection
tool to drag the mirrored copy in alignment with the original half
of the tree.  The example below shows the end result after
alignment of the mirrored objects.

5. Once the mirrored objects are aligned, take the Line tool and make
accent lines within the trees boundary lines.  This adds a more
realistic appearance.

Final Examples



Flip

The Flip command flips any selected object or group of objects horizontally
or vertically.  When flipping objects, the program uses the center of the
selected objects for a reference point.

The Flip command is found under the Edit menu.  The Flip options are found
within a pop-up menu.

Hold down mouse button to access pop-up Menu

For quick access to the Flip Horizontal and Vertical commands use the Menu
Bar buttons.  To turn the Menu Bar On or Off, pull down the Layout menu
or press CTRL M.

Example

The Flip Horizontal command is useful for creating objects that should be
symmetrical along a vertical axis.  An example of this, is if a free-formed shape
is drawn, copy the shape, and then reposition and flip the copy to produce
two free-formed shapes with symmetrical curves and lines.  The Vertical Flip
command works in the same manner, except the objects flip on the Vertical
axis.

Flip Horizontal flips the object along the Horizontal axis.
Think of it as flipping the object to the right of the original object.

Flip Horizontal
Button

Flip Vertical
Button



Vertical Axis Line
Up or Down

Horizontal Axis
Left to Right

Flip Vertical flips the object along the Vertical axis.  Think of
it as flipping the object down from the original object.

Vertical Axis Line
Up or Down

Horizontal Axis
Left to Right



Nudge

The Nudge commands are very useful to move selected objects in small or
large increments without using the Selection tool (Arrow tool).  It sometimes
becomes difficult to move selected objects using the Selection tool (Arrow
tool).  With this in mind, KeyCAD Pro has designed several convenient
ways of Nudging (moving) selected objects.  The distance an object is to
be nudged can be set, by accessing the Nudge Rate Dialog box.

To access the Nudge command pull down the Edit menu, highlight Nudge
and a pop-up menu appears, from which the user can select either Nudge
UP, DOWN, LEFT, or RIGHT.  The Nudge Rate Dialog box can also be
accessed.

The Nudge Pop-up Menu

The Nudge Buttons

KeyCAD Pro has placed Nudge buttons on the Readout display window.
The display buttons support two types of Nudge, i.e., Incremental Nudge
and Absolute Nudge.  The following examples display two types of Nudge.

Nudge Absolute Nudge Incremental
Buttons Buttons



Nudge Absolute

The Nudge Absolute buttons are used to nudge any selected object(s), and
individual vertex points from the Absolute reference point (Origin Point).
The Absolute (Origin) Point is where the axis lines meet.  The program
defaults to the lower left of the screen.

For example, select an object then click on one of the Nudge buttons, either
to the left or to the right and up or down.  The selected object moves in that
direction according to the distance set within the Nudge Rate Dialog box.

NOTE: Remember the reference point from which the Nudge is calculated,
is the Absolute (Origin) point of the design.

 Nudge Absolute Buttons

• Nudge X (Left or Right), when clicking on these buttons the object
moves along the X-Axis.

• Nudge Y (Up or Down), when clicking on these buttons the object
moves along the Y-Axis.

• Click the Nudge buttons as many times as necessary.

Nudge Left or Right

Nudge Up or Down



Nudge Incremental

The Nudge Incremental buttons are used to nudge any selected object(s)
and individual vertex points in Incremental coordinates.  Incremental means
that the selected object is resized in reference to the original size of the object
or points.  For example, if a rectangle is selected and then click on the 
W Nudge buttons, the rectangle changes in width, which changes the size
of the selected object.  The nudge distance is set in the Nudge Rate Dialog
box.

If an object is selected then click on one of the Incremental Nudge buttons,
either W left or right and H up or down, the selected objects change in
Width or Height according to the distance set within the Nudge Rate Dialog
box.

When using the W or H nudge buttons on selected objects, the width and
height are referenced from the center of the selected object.

Incremental Nudge Buttons

• Nudge W, when clicking on these buttons the object changes
along the X-Axis.

• Nudge H, when clicking on these buttons the object changes
along the Y-Axis.

Nudge Height (Up or Down)

Nudge Width (Left or Right)



Setting the Nudge Rate

When using the Nudge commands, the distance an object moves each time
the Nudge command is used can be specified.  To access the Nudge Rate
Dialog box, pull down the Edit menu and drag the cursor on top of the word
Nudge.  A pop-up menu displays.  Now select the Nudge Rate...  Once the
dialog box appears the nudge rate can be entered.  Click OK after entering
the correct rate.  Click on the Cancel button to cancel and return to the
previous setting.

The Nudge Rate Dialog affects all of the Nudge commands.

NOTE: The Nudge Rate is always tied to the current scale of the design.

The Nudge Rate Dialog box

Smoothing

This command is designed to round the angles of polygons, splines and
unsmoothed freehand shapes.  This command can also work conversely by
changing the rounded angles back into sharper angles.

The Smoothing commands can be accessed under the Edit menu; hold
down the mouse button on top of the word Smoothing and a pop-up menu
appears.  From the pop-up menu the Smooth, Unsmooth, and Tension
Dialog box can be accessed.



The Smoothing Pop-up Menu

• Smooth
Smooth changes selected polygons to smoothed splines.  Smooth
rounds the corners of polygons and unsmoothed free-formed
shapes.

• Unsmooth
The Unsmooth command changes splines, smoothed polygons
and any smoothed free-formed shapes into polygons with sharp
angles.

• Tension...
This command is used to access the Tension Dialog box and
change the tension value from which the Smooth command is
tied.  The smoothness of selected objects can be loosened or
tightened.

Using the Smooth command

The following example shows the effects of the Smooth command when
applied to a polygon.

1. First, create a simple open polygon, then select the polygon by
using the Selection (Arrow) tool, so that all of the points within the
polygon are highlighted as shown.



Highlighted points

An Unsmoothed Polygon

2. Now, select the Smooth command from the Smoothing pop-up
menu.  This command automatically smooths the angled corners
of the polygon.

A Smoothed Polygon

Unsmooth
1. After smoothing the polygon, select the smoothed polygon and

choose Unsmooth.  The polygon returns to its original angular
shape.

An unsmoothed Polygon



Tension Dialog Box

The Tension Dialog box is accessed to set the amount of smoothness that
is to be applied when the Smooth command is used.

The Tension Dialog box can be selected from the Smoothing pop-up menu,
which is found under the Edit menu.

When entering the tension value, the smaller the number the tighter the
curves are going to appear.  If the number is too small, the corner points
become angular.  This has a similar effect to the Unsmooth command.

If the tension value is increased, the curve smoothness becomes looser,
taking on a larger curve effect.  If the value is too high, objects can be made
with no straightness.

The Tension Dialog box

Preferences...

This Dialog box is used to personalize KeyCAD Pro.  The program defaults
for tools and commands can be changed.  The Preferences options are
useful to adjust the KeyCAD Pro environment to fit the user's working
habits.

The Preferences Dialog box can be accessed under the Edit menu.  The
Dialog permits a choice of several options.



Zoom Percentage
This setting determines the percentage that the Zoom tool Zooms
In or Out.

Multigon Sides
The number in this box represents how many even sides are
drawn when using the Multigon tool found in the Draw toolbox.

Curve Smoothness
KeyCAD Pro uses splines when creating any curves within the
program.  This setting is used to determine how many points are
placed on each curve segment.  The higher the number, the
smoother the curves appear.  The lower the number, the rougher
the look to the curves

Snap To Tool Sensitivity
This setting determines how close the cursor should be to the
object outline for the Snap To tools to function.  The number
represents how many pixels away from the object the cursor can
be.

The Preferences Dialog box



Snap To Tool Percentage

The percentage value entered in this box determines the point on the line
the Percentage Snap To tool snaps to.  It can be set from 0 to 100%.

Auto Reset Tools

This option can be turned On or Off.  An X in the box indicates that it is On.
This option when turned On, resets the tool selected back to the Arrow tool
(Selection tool), after the selected tool has been used once.  If this option
turned Off, then the tool selected stays selected until another tool is chosen.

Show Clipboard

The Show Clipboard command opens the Clipboard. The Clipboard
window shows the objects or text recently cut or copied to the Clipboard.
The Clipboard is used to copy (duplicate), or move selected objects from
any part of the design to another part, or even to a different file. Objects can
also be moved to other applications that support the Clipboard Cut, Copy,
and Paste commands.

The Show Clipboard window is accessed under the Edit menu.

When Show Clipboard is chosen, a window appears which displays the
most recently copied object or text from the Clipboard.  To close the
window click on the Close button of the window.



The Layout Menu

When using the Layout menu, think of the commands as items that
customize design requirements. The Layout menu allows the user to
access commands such as turning the Menu Bar On or Off, Drawing Scale,
Fit to Window, Axis Lines on or off, Grid specifications, and many other
commands used for creating, viewing, and measuring objects.

Several commands have keyboard equivalents for fast access, when
combining the CTRL key (or COMMAND key on the Macintosh) with
certain letters as shown in the menu below.

The Layout Menu



Menu Bar

The Menu Bar is designed to let the user work efficiently and quickly
within a design.  The Menu Bar can be turned On or Off  by selecting the
Menu Bar command under the Layout menu or pressing CTRL M.

The commands, tools, and options found within the Menu Bar can be
accessed within the various menus found at the top of the screen.

The buttons and pull-down menus have been designed with minimal size.
They  follow along the edge of the title bar to minimize space utilization and
should not interfere with design work.

If the monitor that is being used is smaller than the width of the Menu Bar,
the program cuts off the options furthest to the right.  It cuts off one option
at a time, until the width of the Menu Bar fits within the screen size.

A brief definition of each option found within the Menu Bar is provided on
the following pages.  Further information on these options is available by
referring to the menu that contains the required option.  The Menus  have
more detailed examples on how to use these options in the creation of a
design.  Refer to the Table of Contents at the beginning of this manual for
a list of the commands contained within each menu.



Menu Bar Layout with Names (Windows)

FlipHorizontal

Group

Ungroup
Mirror

Flip Vertical

Lock

Join
Unjoin

Fill Color

Pen Color

Axis Lines

Snapto Grid

Actual Size

Fit to Window

 Unlock
Grid Lines
 On or Off

Eyedropper

Toolbox
    Menu



Menu Bar Layout with Names (Macintosh)

Fill Color

Snap to Grid

Grid Lines
 On or Off

Pen Color
FlipHorizontal

Mirror

Ungroup

Line Type

Fill Pattern

Tools Menu

Import Image

Copy

Cut Paste

Print

Save File As

Open Image

New Image

Group

Flip Vertical



Mirror
This button is used to duplicate and flip a selected object.  The
mirrored object is slightly offset from the original.  To use the
Mirror command, first select the object then click on the Mirror
button within the Menu Bar.  Individual objects or groups of
objects can be mirrored.

Flip Vertical
This button is used to Flip selected objects along the vertical axis,
comparable to flipping the selected object upside down.  Individual
objects or groups of objects can be flipped.

Flip Horizontal
This button is used to Flip selected objects along the horizontal
axis, comparable to flipping the selected object to the right.
Individual objects or groups of objects can be flipped.

Group
This button is used to consolidate a set of selected objects as one
grouped object.  A grouped set of objects is treated  as a single
object, rather than several individual objects.

Ungroup
The Ungroup button automatically divides a grouped object into
individual objects.

Lock (Windows only)
This button is used to Lock the characteristics and location of any
selected object or groups of objects, so that they cannot be
changed.

Unlock (Windows only)
This button is used to unlock locked objects.

Join (Windows only)
This button is used to connect (Join) all selected lines or arcs that
share overlapping (connected) end-points.



Unjoin (Windows only)
The Unjoin button disconnects all selected lines or arcs that have
been previously Joined.

Eyedropper (Windows only)
The Eyedropper tool is used to select the current color from any
color currently in use within a design.  Once the Eyedropper tool
is clicked on a color within the design that color  becomes the
current color.  The color that was clicked on is then displayed in
the Current Color button.

 Fill Color
 The current Fill color is displayed to the right of this button.  To
select another fill color, click once on the button to open the color
picker.

Pen Color
The current Pen color is displayed to the right of this button.  To
select another pen color, click once on the button to open the color
picker.

Grid Lines On or Off
The Grid button turns the Grid Lines On or Off, depending on the
current status of the Grid Lines when the button is clicked.

Snap To Grid
This button is used to turn the Snap To Grid option On or Off.

Axis Lines On or Off (Windows only)
Clicking this button toggles the Axis Lines On or Off.

NOTE: The Axis Lines represent the Origin point, a reference site for all
Absolute coordinates and Readouts.

Fit to Window (Windows only)
This button automatically makes the entire design fit within the
current window size.  This is useful for viewing  the overall layout
of a design.



Actual Size (Windows only)
This button displays a design at its actual size.  This is very useful
to return to Actual Size without using the Zoom tool or Menu
command.  This command may be accessed from the Options
menu or by pressing CTRL+E.

New Image  (Macintosh only)
This button is used to create a new image at the default settings.
Selecting this button is the same as selecting the File menu, New
option.

Open Image  (Macintosh only)
This button displays the Open Image window.You can locate
and open previously created documents.

Save  (Macintosh only)
This button allows you to save the currently active file. If the file
has been saved previously then this button saves the document
over the original document.

Print  (Macintosh only)
This button displays the print dialog box. This dialog box allows
you to set printer options and print the currently active document.

Cut  (Macintosh only)
This button removes selected objects from a document and
places them on the clipboard.

Copy  (Macintosh only)
This button places the selected objects in the clipboard while
leaving the original objects in the document.

Paste  (Macintosh only)
This button places the contents of the clipboard into the currently
active document.

Line Type  (Macintosh only)
This button allows you to select a line style for any selected
objects.



Fill Patterns  (Macintosh only)
This button displays the Fill Pattern Window.

Import Image  (Macintosh only)
This button allows you to import a previously saved image into
the currently active image.

Toolbox Pull-Down Menu
This pull-down menu turns On or Off any of
the toolboxes found within the program.

The Toolbox Pull-Down Menu

A checkmark beside an entry indicates that the Toolbox is currently
displayed on the screen. The diagram above shows the program defaults



Rulers

To turn on the Rulers, either choose the Rulers command from the Layout
Menu or press CTRL R.  To turn them off choose Rulers again from the
Layout Menu or press b R again.

The rulers show the current ruler scale settings of the document.  To change
these settings, either choose Rulers/Scale from the Layout Menu or, if the
rulers are on, double-click on either the unit of measure readout, horizontal
or vertical ruler.

The vertical ruler does not start at 0 at the top, but at the bottom.  This is
because the Origin point is in the lower left.

The horizontal and vertical rulers also change if you change the document’s
paper size, origin point, or if you click on the Actual Size or Fit to Window
buttons (or their menu equivalents) in the Menu Bar.

Unit of Measure Readout

To the left of the horizontal ruler and at the top of the vertical ruler, is the
Unit of Measure Readout which indicates the current screen unit of
measure.



Rulers/Scale...

The Rulers/Scale Dialog box is used for setting the scale to work in when
creating a design. KeyCAD Pro supports all of the scales used in today’s
engineering fields.  It is also used to set the unit of measure and the number
of divisions a unit on the ruler will be divided into.

Scale factors are very useful when working on precise designs that are
larger than the paper needed to print the design.  Working with scaled
drawings, requires knowledge of how a design proportionally fits with
respect to the real world coordinates.

The program defaults to 1" (in.) on the screen equals 1" (in.) in the real
world and 16 ruler divisions. Once the scale and ruler settings are changed
they stay at the new setting until they are changed again.  Below are some
example scales that are commonly used.

1/16 in. =  1 ft.
1/8 in. =  1 ft.
1/4 in. =  1 ft.
1/2 in. =  1 ft.

The Rulers/Scale Dialog Box



These scales are more commonly used in Architectural designs.  Since
most Architectural designs are very large in real life, a small scale factor
is needed to permit the design to fit on a reasonable size of paper.

KeyCAD Pro Rulers/Scale Dialog supports both English and Metric
scales.

Example

Below is a simple room presented in two different scales to assist in the
comprehension of how scales can benefit a design.

1. Create the room 1" = 1" scale factor. Notice that the size of the
room is very small in comparison to the real world size of the same
room.

2. Now create the same room but use 1/8" = 1' scale factor, to show
the real life measurements.

2.000" 

1.250" 

0.375" 



Setting the Drawing Scale

Set the Drawing Scale at the begining of the design , when a new file is
first started.

When setting the scale factor consider setting the Display options to
display the proper units of measurement.

1. Pull down the Layout menu and select Rulers/Scale or, if the
rulers are on, double click on either the unit of measure readout,
horizontal or vertical ruler.  A dialog box like the one shown on
page 8-10 appears asking the user to set the desired scale, unit
of measure, and number of ruler divisions.  At the top of the
dialog box there is a sample view of what the rulers will look like
if they are turned on.

2. Type the desired screen unit in the edit field under the Screen
Units: heading.

3. Type the desired world unit in the edit field under the World
Units: heading.

4. Choose the desired unit of measure for the screen scale from the
pop-up list box below the screen scale edit field.

 16'-0" 

 10'-0" 

 3'-0" 



5. Choose the desired unit of measure for the world scale from the
pop-up list box below the world scale edit field.

6. Choose the desired number of ruler divisions from the Minor
Divisions pop-up list box.

To rescale all of the objects in the drawing to the new settings,
make sure the box next to Rescale Objects is turned on.  To turn
it on, click once on the box, an X appears in the box to indicate
that it is on.  If it is on (X in the box) and you want to turn it off,
click once on the box and the X disappears.

The readouts at the bottom of the screen change accordingly to reflect any
changes.

The Sample Ruler

There are two sample rulers displayed at the top of the dialog box.  The top
ruler shows the screen unit of measure (inches, millimeters or centimeters).
The bottom ruler shows what the rulers will look like if they are turned on.
The lines on the rulers are called “tick marks” and vary in height depending
on whether there is a major or minor division of the unit of measure.

Between the two sample rulers is an arrow that shows how many screen
units make up a screen unit of measure (inch, millimeter, centimeter).

As the values for the screen units, world units, screen unit of measure and
number of ruler divisions are changed, the bottom ruler is updated to show
what effect  changes will have on the rulers.  As the values for the screen
unit of measure and number of divisions are changed, the top ruler is
updated.  As the values of screen units, world units and screen unit of
measure are changed, the arrow between the rulers is updated.



Screen Units

In the edit field below the heading Screen Units: the desired screen unit
can be entered.  Below the edit field, there is a pop-up list box where the
screen unit of measure is chosen.  Cchoose from Inches, Millimeters, or
Centimeters.

NOTE:  Millimeters are shown on the sample rulers in groups of 20
millimeters instead of individual millimeters.  Each tick mark on the rulers
is 2 millimeters.

World Units

In the edit field below the heading World Units:  the desired world unit can
be entered.  Below the edit field, there is a pop-up list box where the world
unit of measure is chosen.  Cchoose from Inches, Feet, Yards, Miles,
Millimeters, Centimeters, Decimeters, or Meters.

Minor Divisons

The Minor Divisions list box allows enables the user to change the number
of divisions that a unit of measure will be divided into.  The number of
divisions are indicated by tick marks.  If inches are chosen, the possible
number of divisions listed are 1-16.  If millimeters are chosen, the Minor
Divisions list box is hidden and the program uses 5 divisions.  To unhide
the list box, chose either inches or centimeters.  If centimeters are chosen,
the possible number of divisions listed are 1-5.

Rescale Objects

The Rescale Objects box can be selected to automatically update any
previously drawn objects.  If the Rescale Objects is not selected, then only
the objects drawn from this point take on the new scale factor.  This allows
multiple scale factors within one document.



Fit to Window

This command provides an overview of the entire document by fitting it
to the current window size.  This command is useful for designs that cover
several pages.  The view can be changed to see how the whole design looks,
and ensure a proper fit on the selected paper size.  KeyCAD Pro reduces
or enlarges the size of a design to permit viewing of it in its entirety within
the current window size.

The Fit to Window command can be selected under the Layout menu.

Fit to Window Menu command

KeyCAD Pro also allows the option to use the Fit to Window button on the
Menu Bar.  To activate the Menu Bar, either pull down the Layout Menu
or press CTRL M.

Axis Lines

The Axis Lines command turns On or Off the Axis lines on the screen.  The
axis lines represent where the X & Y axis lines meet.  This is considered
the Absolute reference point of the design.  When the program is first
started the axis lines appear in the lower left-hand corner of the screen.  The
axis lines can be moved by selecting the Move Origin under the Options
Menu.

X-Axis runs horizontal or (left to right).

Y-Axis runs vertical or (up and down).



To access the Axis Lines command pull down the Layout Menu. A check
mark beside the name indicates that the axis lines are on.

KeyCAD Pro offers the option of using the Axis Lines button found on the
Menu Bar.  The Menu Bar command can be activated under the Layout
Menu, or press CTRL M.  Click on the button, to turn the lines On or Off,
like a toggle switch.

Page Breaks

This command permits viewing of how a drawing divides into pages for
printing purposes. It shows the page breaks of any file (document).  A page
break appears as dashed lines on the screen.  The design may extend over
the page break lines.  The dashed lines DO NOT print; they represent where
KeyCAD Pro divides the drawing into printed pages.  The page break lines
are in accordance with the page size and orientation selected in the Page
Setup Dialog box.

Page break lines cannot be moved or adjusted on the page where they
appear on the design.  KeyCAD Pro automatically sets the page break
positions based upon the settings chosen in the Paper Size and Page Setup
Dialog boxes.

To display Page Breaks choose the Page Break
command from the Layout Menu.



To hide the page breaks, choose the Page Breaks command
again and the lines disappear.  The Page Breaks command
works as a toggle switch.

Grid

The Grid options are accessed through the Grid pop-up menu, which is
found under the Layout menu.  Drag the mouse cursor on top of the word
Grid and a pop-up menu appears as shown below.  Within this menu the
user can choose to turn the Grid lines On or Off, Snap To Grid, and set
the Grid Spacing.

The Grid Pop- Up Menu



Grid Lines

Grid lines are evenly spaced on the screen and can be used as reference
points when creating a design.  These lines assist in accurately positioning
and adjusting the size of objects.  The space between each grid line can be
set to a specific distance.  To change the grid spacing, select the Grid
Spacing command; a Dialog box appears which allows the grid spacing to
be set.

The Grid Lines option works like a toggle switch, and the check mark
beside the option means that the grid lines are On.  Select the Grid Lines
option to turn them Off and the check mark disappears.

To turn the Grid Lines On or Off click on the Grid Lines button found on
the Menu Bar.  The Menu bar appears under the title bar of the window.  The
Menu Bar can be turned On or Off from the Layout menu or by pressing
CTRL+M.

Snap To Grid

To ensure that objects drawn conform exactly to the Grid, turn On the
Snap to Grid option.  When the Snap to Grid option is turned On,
KeyCAD Pro restricts the sizing, placement, and drawing of objects to
the spacing of the grid.

Objects only change size in increments of the grid spacing when the Snap
to Grid option is activated.  Objects cannot move to positions between the
grid points.  The boundary lines of the object can be moved to align only
with the grid lines.

Turning on the Snap to Grid

To turn on the Snap to Grid option select it from the Grid pop-up menu
found under the Layout menu.  The option works like a toggle switch, and
when the Snap to Grid is On, a check mark appears beside the name.

Alternatively turn the Snap to Grid On or Off by clicking on the Snap To
Grid button found on the Menu Bar.  Turn the Menu Bar On or Off by
selecting the command under the Layout menu or by pressing CTRL+M.



For more details concerning the Menu Bar refer to the MenuBar section
of this chapter.

Grid Spacing...

The spacing between the horizontal and vertical grid lines can be set by
accessing the Grid Spacing Dialog box.  The grid spacing can be set for
both the Horizontal and Vertical lines.

Access the Grid Spacing Dialog box by selecting the Grid Spacing option
found in the Grid pop-up menu, which is found under the Layout menu.

With the appearance of  the Dialog box, type in the horizontal and vertical
distance required.  The horizontal and vertical distances do not have to be
the same.  Once the desired settings have been entered click on the OK
button and the Grid lines are automatically updated to reflect the new
settings.  The Dialog can be cancelled by clicking on the Cancel button, and
the program returns to the previous settings.

The Menu Bar Command

The Grid Spacing Dialog Box



Align to Grid

The Align to Grid command automatically aligns individual or groups of
objects to the current grid spacing.

Using the Align to Grid

1. Select the object to align to, by using the Selection tool.
2. Turn on the Align to Grid command by selecting it from the

Layout menu or press CTRL+R.
3. Now, select the End-Point Snap To tool and click on the vertex

point within the object to align to the grid.  Clicking on the point
with the Snap To tool tells the program which point to snap to the
grid.

4. After snapping to the desired point, while holding down the
mouse button drag the object to the closest grid point and release
the mouse button. The object is automatically aligned to the grid
point.

NOTE: The Snap To tools must be used when aligning objects to the grid.
This is so the program can identify which point of the object is to be
aligned to the grid.  Any of the Snap To tools can be used when using the
Align to Grid command.

Dimensioning

The Dimensioning pop-up menu allows the user to access several options
for the dimension tools.  Most options work like a toggle switch, and have
check marks beside them to indicate that they are on.  These options include
Arrows In, Arrows Out, Center Text, Text Frame, Single, Double, Limiting
Tolerances.

The Tolerance Values Dialog box can be accessed from the Dimensioning
pop-up menu.  This Dialog is for setting the upper and lower tolerance
values for the Limiting Tolerance option.



The Arrowheads pop-up menu is where the type of arrowhead for the
dimension lines is selected.

Using these options enhances the custom appearance of the document and
helps in using industry standard methods of drafting.

The Dimensioning Pop-up Menu

Dimensioning Options

Arrows In

This option makes the Arrows appear on the inside of the witness lines.
The example below displays how the arrows look when using the Arrows
In option.



Arrows Out

This option makes the Arrows appear on the outside of the witness lines.
The following example displays how the arrows look when using the
Arrows Out option.

Arrowheads

The Arrowheads pop-up menu provides the Arrowhead types available for
selection with dimensions.  The following example displays the available
options.

Center Text

When selecting this option the text that appears with the dimension is
automatically centered between the witness lines.  This is useful to alter the
size of an object that is already dimensioned.  The text remains in its
original position until the dimension is selected and Center Text is chosen.

Text Frame

After selecting the Text Frame option, the dimension text automatically has
a box drawn around the text.  The example below displays how the Text
Frame appears.

The Arrowhead Pop-up Menu



Single Tolerance

This option displays a tolerance value with the dimension text.  The
Tolerance option can be combined with the Text Frame option as shown
in the examples below.  To set this tolerance value, choose Tolerance
Values from the pop-up menu and set the upper tolerance to the required
specifications.

Single Tolerance with Text Frame

Single Tolerance without Text Frame

Double Tolerance

This option displays the dimensions with a double tolerance value, i.e. an
upper and lower tolerance value.  To set these upper and lower values,
access the Tolerance Values Dialog box.  The Double Tolerance option
can be displayed with or without a text frame.  The following examples
show how the options appear with a dimension.

Examples of Double Tolerance options

Double Tolerance with Text Frame



Double Tolerance without Text Frame

Limiting Tolerance

When choosing this option the dimensions appear with a double dimension
value that has added the upper and lower tolerance values to the actual
dimension.  The examples below illustrate this option.  The upper tolerance
value is set to 0.050 and the lower tolerance value to 0.000.  These values
are automatically added to the original dimension.  The values can be set
in the Tolerance Values Dialog box found within the Dimensioning pop-
up menu.

Original dimension

Dimension after selecting the Limiting Tolerance option

Limiting Tolerance with Text Frame

Tolerance Values

The Tolerance Values Dialog is where the upper and lower tolerance
values that are applied to the Single, Double and Limiting Tolerance
options are set.  The following diagram illustrates the Tolerance Values
Dialog box.



The Tolerance Values Dialog box

Draw Parallel

This command draws all objects with a parallel relationship.  Select the
Draw Parallel command or press CTRL Y before starting to  draw the
object.  The parallel options can be set within the Parallel Dialog box,
which is found under the Layout menu, and is discussed in the next
section.

     Draw Parallel Example

Parallel...

The Parallel Dialog box is used to set the parallel options for drawing
parallel objects.  There is a choice of drawing the parallel to the Inside,
Outside, or Center of the original object.  The distance that the parallel is
to be offset from the original can also be specified.



The Parallel Options Dialog box

Draw from Center

This command sets the Draw tools to always draw from the objects center.
When using this command the readouts display half of the objects width
and height, due to the fact that it is drawing the object from the center.  To
draw a circle with a specific radius, select Draw from Center and the width
and height readouts display the radius.

Fill Color...

The Fill Color is the color that is used to fill in an object.The Fill Color can
be changed by selecting Fill Color... under the Layout menu or by clicking
on the Fill Color button (paint bucket) in the Menu Bar.This brings up the
color picker within the program.

The color picker is used to choose any color or grayscale that is available
to the hardware.The current fill color is shown to the right of the Fill Color
button in the Menu Bar.The Menu Bar can be turned On or Off from the
Layout menu, or by pressing CTRL+M.

KeyCAD Pro provides an easy method to select a fill color that may have
previously been chosen for an object within the drawing.  Use the
Eyedropper tool to conveniently change the fill color in the color picker.



NOTE: If Fill Color option under the Layout menu does not fill the object
with the desire color, make sure the Fill Color Pattern 1, as shown above,
is selected in the Fill Patterns Box.  You can access the Fill Patterns Box
under the Options menu.  Fill Color Pattern 1 is the first pattern in the third
row from the top.  Fill Pattern 2 fills the object with white space.

Using the Eyedropper tool (Windows only)
1. Click on the Eyedropper tool, which is found on the Menu Bar.
2. Place the tip of the Eyedropper on top of the color to be selected,

and click the mouse button.
3. Notice that the color button changes to the color that was clicked

on.  This new color stays active until it is changed again.

Pen Color...

The Pen Color is the color that is used to outline an object. The Pen Color
can be changed by selecting Pen Color... under the Layout menu or by
clicking on the Pen Color button in the Menu Bar.

This brings up the color picker within the program.  The color picker is used
to choose any color or grayscale that is available to the hardware. The
current pen color is shown to the right of the Pen Color button in the Menu
Bar.

The Menu Bar can be turned On or Off from the Layout menu, or by
pressing CTRL+M.

Readouts

The Readouts pop-up menu gives access to the options available for the
Readouts window.  From the pop-up menu the readouts can be set to
display certain levels of precision.  The readouts can also be set to display
feet and inches.  A check mark, indicates which option is active.

Fill Color Pattern 1 Fill Color Pattern 2



The Readouts Pop-up Menu

The diagram  below shows the Readouts window, which appears at the
bottom of the screen.  These readouts can be turned On or Off, and can be
moved to any location on the screen.

Lines

The Lines pop-up menu is used to choose from the different Types and Size
of lines.  The choice of lines consist of plain lines, centerlines, and different
types of dashed lines.  The line size applies to all line types.

 Lines Pop-up Menu

The Readouts Window



Changing Line types

To change the line type of an object, proceed as follows:
1. Select the object then pull down the Layout menu and access the

Lines pop-up menu, to select the required line type.
2. Only the selected objects change to the new line type.

Line Size

This Dialog box is used to select the line thickness that appears when
using the Draw tools.  The lines are determined by point size.  The Dialog
box displays the line width after the point size is entered.  Use whole
numbers such as 1, 2, 3, etc.  There is a choice from 1 to 20 on the line size.

The Line Size Dialog Box

The Line Type Dialog Box



1  point line

2 point line

6 point line

8 point line

 4 point line

The following examples illustrate how different lines sizes look when
printed.



The Options Menu

The Options menu is where various settings available to the program are
selected.  Some of the commands available are filling objects with Fill
Patterns, Lock or Unlock objects, Join or Unjoin objects, Group or
Ungroup, Move Origin, and Actual Size.

Several of the Options menu commands can also be accessed from the
Menu Bar (refer to Menu Bar section) or by using the Control key
(Command key on the Macintosh Version).

   Menu Bar Buttons Menu Commands

               Lock

               Unlock

               Join

               Unjoin

               Group

               Ungroup



Fill Patterns

The Fill Patterns window gives access to the various fill patterns.  A fill
can be applied to any object such as polygons, circles, rectangles, squares
or multigons.  If an object is made up of  lines and arcs, the different
elements of the object must first be joined together prior to filling it.

To select a fill pattern pull down the Options menu and drag the mouse
on top of Fill Patterns.  When the window appears, move the mouse cursor
on top of the desired fill and click the mouse button.

The Fill Pattern Window

Select a fill pattern; on returning to the Fill Pattern menu, the  selected fill
is identified by a white frame. This indicates that a fill is currently selected.



Applying a Fill Pattern to an object
1. Select the object to be filled. More than one object can be selected

by holding down SHIFT while clicking on additional objects.
2. Now, select the desired fill from the Fill Pattern window.

Filled Objects

When an object is already filled and further edits are  done to the size or
shape of the object, the fill pattern is automatically updated to reflect the
changes.

Lock and Unlock

Objects within the document can be Locked to prevent them from being
accidentally moved, edited or deleted.  When an object is locked it cannot
be cut, deleted, moved, rotated, mirrored or flipped.  No changes can be
made to its' appearance, stacking order (layer) size, alignment to the grid,
smooth, unsmooth, or shape of the object. However, the user can copy and
duplicate a locked object.

If a locked object is included among objects selected for grouping,
KeyCAD Pro keeps that object locked even though it is grouped with other
objects.

The Lock command is found under the Options menu; or use the Lock and
Unlock buttons found on the Menu Bar.  The Menu Bar is turned On or Off
from under the Layout Menu.



NOTE: An entire document can be protected by selecting all of the objects
in the document and locking them.  When locked, none of the objects can
be changed.

Locking an Object
1. Select the object by clicking on it with the Selection tool.
2. Choose the Lock command from the Options menu or click on

the Lock button found on the Menu Bar.

Unlocking an Object
1. Select the object(s) to be Unlocked, by clicking on it with the

Selection tool.
2. Choose the Unlock command from the Options menu, or click

on the Unlock button found on the Menu Bar.

Join and Unjoin

When Join is selected from the Options menu or the Menu Bar, the
program automatically connects all line segments with overlapping end-
points.  Overlapping means that the end-points are connected by snapping
them to each other, (using the Snap To tools).  The Join command combines
individual line segments, arcs, polygons, and free-formed splines into one
polygon.

Overlapping end-points

The Join command turns individual line segments and arcs into polygons.
Perform any of the procedures or choose any of the commands to use with
open or closed polygons. Joined objects can be resized, reshaped, smoothed
or filled.

Join can be selected from the Options menu or the Menu Bar. Select
objects prior to choosing the Join command.



How to Join objects
1. Select the objects to join, by using the Selection tool and holding

down SHIFT swhile clicking on the individual objects. (Use the
appropriate Snap To tool to ensure that the end-points are
overlapping).

2. Now, select the Join command from the Options menu or  from
the Menu Bar.

Unjoin

When Unjoin is selected from the Options menu, any selected objects are
automatically disconnected from each other.  Unjoin separates the segments
that have been combined into one joined polygon, therefore making them
individual line segments.  Unjoin  divides rectangles, rounded rectangles,
polygons or circles into individual line segments.

The Unjoin command can be selected from the Options menu or from the
Menu Bar.

How to Unjoin objects
1. Select the object, by using the Selection tool from the Edit

toolbox.
2. Then, select the Unjoin command from the Options menu, or

from the Menu Bar.

Bring to Front

The Bring to Front command from the Options menu, moves any selected
object to the front of the stacking order.  This command can be used to move
an object to the front of the stacking order so that it can be edited.  After
editing the object  move the object to the back of the stacking order.  If
several objects are selected and then Bring to Front is chosen, all selected
objects move together in front of the unselected objects.  The transposed
objects remain in the same stacking order they were prior to the command.
Choose the Bring to Front command from the Options menu, or press
CTRL F.



Send to Back

The Send to Back command moves any selected object to the last position
of the stacking order.  An object moved to the back can be partially or
totally obscured from view by other objects placed in front. Although
obscured, the object remains selected and it can be moved to the front if
necessary.  The Send to Back command can be selected from the Options
menu, or press CTRL B.

To move an object Front or Back
1. Select the object(s). This command also works with grouped

objects.
2. Then, select the desired command and the selected object is

moved to the Front or Back depending on which command is
selected.

Group and Ungroup

Designs can be made of many different individual objects.  A design may
need to consolidate, or group, several objects into one object, to make
working with a design easier.  Once objects are grouped; it enables them
to be manipulated as one object.

Ungrouped objects selected

Same objects grouped and selected as a group



Notice in the previous example that the objects have individual boundary
points when not grouped.  After grouping the objects, they share the same
boundary points.

Clicking on a set of grouped objects selects the entire group simultaneously.
It is possible when working with grouped objects, to resize, delete or
duplicate them.  Once a set of objects are grouped, the individual objects
that make up the group cannot be changed, unless the objects are first
ungrouped.

Objects can only be grouped on the same layer.  When objects for grouping
are selected, they appear at different positions in the object stacking order.
Once these objects are grouped, they take on the stacking order of the
foremost grouped object.

Grouping Objects
1. Select the objects to be grouped, by clicking on the individual

objects, use the Selection tool and hold down SHIFT.  Alternatively
a selection rectangle can be drawn around the objects.

2. Choose Group from the Options menu, or click on the Group
button found on the Menu Bar, or press CTRL  G. Once the
objects are grouped, a display of boundary points are exhibited
around the grouped objects.

Ungrouping Objects

To ungroup any grouped objects, to make any changes to the individual
objects within the group.  Ungrouping of an object breaks that object into
the individual objects again.  Locked objects cannot be ungrouped.  Unlock
the objects first, using the Unlock command.

1. Select the grouped objects by clicking on them with the Selection
tool.

2. Choose Ungroup from the Options menu, or click on the
Ungroup button found on the Menu Bar.



Once grouped objects are Ungrouped, changes can be made to each
individual object. KeyCAD Pro automatically highlights the selected
objects.

Move Origin

The Move Origin command is used to move the Absolute point of the
design.  The Absolute point is the point from which all absolute coordinates
are calculated from.  The Absolute coordinates are considered the X and
Y coordinates or the horizontal and vertical distance from the zero point.
The Origin point is where the horizontal and vertical axis lines intersect.

The Origin point can be moved to any location on the current document.
Moving the Origin point affects all layers.

The Move Origin command can be accessed from the Options menu.

Actual Size

Use the Actual Size command to return the current document back to the
100% view.  Actual Size means the measurement on the screen is the size
the document is to be printed.

Actual Size is useful for removing any Zoom In or Out commands that may
have been performed.  The design returns to 100% viewing.

The Actual Size command can be accessed from the Options menu, or
press CTRL E.



The Windows Menu

The Windows menu provides access to various options that affect the
characteristics of the drawing window setup.  The options are: Scrolling
Speed, Background Color, Title Options and Toolboxes. The list of
currently open files is drawn at the bottom of the menu, selecting a filename
makes that document active.

The following diagram shows how the menu appears within the program.

The Windows Menu

Scrolling Speed

The Scrolling Speed Dialog box is used to change the speed at which the
document scrolls when clicking on the Scroll Arrows. The Scrolling Speed
is determined by the number of pixels the document moves before it
redraws the screen. The Pixel setting can be changed in two different ways;
either click on the small arrows next to the numeric display, or highlight the
numeric value and type in the new setting.  The program defaults to 50
pixels.  The higher the number the faster the document scrolls.



The Scrolling Speed Dialog box

Once the desired speed has been entered, click on the OK button and the
new settings  become effective.  Click on the Cancel button to cancel any
changes made.

Background Color

The Background Color option is used to change the background color of
the document. If there are any objects that have no fill to them, the
background color appears through the objects.  The background color
covers the entire page size of the current document.

The Color Dialog Box
for Windows



The Color Dialog Box
For Macintosh

When the Background Color is selected from the Windows menu, a Color
Picker Dialog box appears.  Choose from any color available to the current
video hardware.  KeyCAD Pro supports up to 16.8 million colors.

The Red Green Blue values of any color can be changed, as well as the Hue,
Saturation, or Brightness of the selected color.  Once the color is set, click
on the OK button, or click on the Cancel button to return to the previous
background color.

Title Options

KeyCAD Pro offers several different options for titling documents.  These
options consist of the Drawing Name, Drawing Name / Axis, Axis and
Layer Name.

The Title Options Pop-out Menu



Select the Title Options by accessing the Title pop-out menu under the
Options menu.  The document title can be changed at anytime during the
design process. The selected title appears in the middle of the Title Bar at
the top of the screen. If the Layer Name option is chosen, only the active
layer name appears.

Toolboxes

The toolbox pop-out menu turns On or Off any of the toolboxes, as well as
the Readout display at the bottom of the screen.  There is access to the Edit
toolbox, Draw toolbox, Snap To toolbox, Dimension toolbox and Position
Info (readouts).  A check mark beside the name indicates that the toolbox
is active.

The Toolbox Pop-up Menu

The Toolboxes can also be accessed from the Menu Bar. This pull-down
menu is designed to turn On and Off the tools.  The Menu Bar can be turned
on by pressing CTRL M or by pulling down the Layout menu.

The Tools Pull-down Menu



The Layers Menu

The Layers menu is where the user can control the various layers.
KeyCAD Pro allows the user to add information to a document in
separate layers, which act as transparent overlays.  Layers are used to hold
or display various aspects of a design.  A single layer can contain and
display different aspects of a design,  KeyCAD Pro supports up to 256
layers.

Creating a Layer

To create a new layer in KeyCAD, follow the steps below:
1. Choose Layer Info... from the Layers pull-down menu.
2. Type a new Layer Name in the Layer Name Dialog box.
3. Click on New, OK.

When the Layers option from the Layers menu is selected, the new layer
name will appear in the drop down box. Click on the newly created layer
to make it the currently active layer.

Hiding a Layer

To hide a layer, follow the steps below:
1. Go to the Layers option in the Layers menu to see the currently

activelayer, which is denoted by a check mark. The currently
active layer cannot be hidden .

2. Now go to Layer Info.. option and click on the layer that you
wish to hide.

3. Click on the Hide button then on OK.

All portions of a drawing within a hidden layer are not dsiplayed on the
screen.



The Layers and Layer Names Pop-up Menus

The Layers Information Dialog box

Showing a Layer

To display a previously hidden layer, follow the steps below:
1. Choose the Layer Info... option from the Layers menu.
2. Click on the layer to be displayed.
3. Click on Show then OK.

All portions of the drawing which were previously Hidden will now Show
on the screen.

An example of the use of Layers would be to draw a floorplan on one layer,
adding the windows and doors of the floorplan to a different layers and the
dimensions of the floorplan to another layer.  Each layer can be separately
named for easy access.
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Layers 1 and 2: The diagram below shows both layers 1 and 2.

Example

The example below explains how the user can have different information
on separate layers.  Notice that the separate layers information still
pertains to one design and not separate designs.

Layer 1: Contains the original design created.

Layer 2: Contains the dimensions of the design on Layer 1,
while Layer 1 remains hidden.



The Layers Information Dialog box

Layer Names Pop-up Menu

Under the Layers menu there is access to the Layer Names pop-out menu.
This menu displays the names of the layers.  The program defaults to one
untitled layer.  A check mark beside the layer name indicates that the layer
is active.

Layers Name Pop-up Menu

Layers Dialog box

Working with the layers provides the option of naming the layer, showing
individual layers, showing all layers, hiding layers, hiding all layers,
adding new layers, renaming layers, or removing layers.  The Dialog lists
the names of the layers to help choose the layer to assign any attributes to.
A dot beside the layer name indicates that the layer is visible.



The Text Menu

The Text Menu allows the user to edit words, sentences, and paragraphs
that are created using the Text tool (found in the Edit toolbox).  KeyCAD
Pro provides the ability to label charts, to display measurements and to
give titles to objects and designs.  This chapter shows how to change the
font, the style, the size or the alignment of a text block in order to place text
anywhere in a design.

Four corner points represent the borders of a text block.  When a text block
first appears on the screen, the default size is about 1.5 inches by 1.5 inches.
The size of the text block can be altered by using the Selection tool.

The appearance of text is governed by the selections in the Text Menu.  To
change the appearance, select the text to be changed using the Text tool,
then select one of the Font and Text Menu options.  Only the selected or
highlighted text is affected by the change.

The initial font style that KeyCAD Pro is set to is Arial 12 point.  The font
style is easily changed using the Text tool and the Text menu.

Windows                                                                      Macintosh

 The Text Menu



Font

Fonts are different types of lettering styles that are installed within the
System. For adding and removing fonts, refer to the Windows User
Manual.

How to change Fonts
1. Highlight the text to be changed with the Text tool by clicking

the mouse  button and dragging the highlight bar across to the
end of the desired text.  (To highlight individual words, double
click on them.)  The highlighted area is blackened.

2. Pull down the Text Menu at the top of the screen and choose
Fonts.... Select the desired font, style and size, by clicking on the
options within the Font Dialog.
On the Macintosh version of KeyCAD Pro , pull down the Text
Menu and select Font. This will allow you to select the desired
font.

Unlike most programs of this nature, KeyCAD Pro remembers the last
selected font.  This means that after any font is changed, all subsequent text
is written with or uses the same font style until it is changed again.  For
example, if some text was changed to Courier with the Text tool and then
an object is created, when the Text tool is used again, the Courier font is
still chosen.

The Font menu displays a list of all fonts available in the current system.
To add and remove fonts from the System refer to the Windows User
Manual.  KeyCAD Pro supports PostScript and TrueType fonts.

The Fonts Menu



Size

The size of text is regulated by the Size function in the Font Dialog.  The
initial or default point size of text is 12.  The size can be raised or lowered
depending on the requirements.

How to change Font Size
1. Highlight the desired text by clicking the mouse and dragging it

across the words to be changed.  (Individual words can be
highlighted by double clicking on them.)  The highlighted text is
blackened.

2. Pull down the Text Menu at the top of the screen and choose the
Font Dialog. Select the desired font, style and size, by clicking on
the options within the Font Dialog.
On the Macintosh version of KeyCAD Pro , pull down the Text
Menu and select Size. This will allow you to select from the font
size options for the font selected.

Under the Size menu only certain point sizes are shown. The numbers
shown are the recommended sizes to receive the best quality text.  KeyCAD
Pro supports other point sizes, however, the text quality may be inferior.
Font sizes are determined for each individual font, when the actual font is
installed within the System.

The Size Menu

KeyCAD Pro allows point sizes that are larger than 18 points.  For larger
point sizes highlight the point size above the scroll bar selections.  Type
in a whole number for the point size and press e or click on the OK button.



Style

Font styles are useful for adding a special touch to text within any
document.  KeyCAD Pro supports several styles such as Regular, Bold,
Bold Italic, and Italic.  Additional styles are available depending on the
font selected. Any of the styles can be combined with any Font or Font Size.
The KeyCAD Pro default Style is Regular text.  The style can be changed
at any time.

How to change Font Style
1. Highlight the text with the Text tool by clicking the mouse and

dragging it across the desired text.  (Double clicking on words
highlights them.)  When highlighted, the selected text is
blackened.

2. Pull down the Text Menu at the top of the screen and choose the
Font Dialog. Select the desired font style, by clicking on the
option within the Font Style menu. Multiple font styles can be
applied to one text block.
For the Macintosh version of KeyCAD Pro, pull down the Text
Menu and select Style. This will allow you to select a style to
apply to the selected text.

The Style Menu

Align

The last three options under the Text menu are Align Left, Align Right,
and Align Center.  These three options are used to justify the text inside
a text block.  This option makes it easier to place text on designs.  The
default mode is Align Left.  The mode can be changed in order to create
right or center aligned text, as in headlines or titles.



How to Change Text Alignment
1. Highlight the text using the Text tool by clicking at the beginning

of the block and dragging across to the end of the text.  (Individual
words are highlighted by double clicking on them.)  Highlighted
text is blackened.

2. Pull down the Text menu at the top of the screen and choose the
appropriate Align options.

Alignment Options

The Text Menu

Below are some examples of the alignments and how they appear within a
text block.

 Text Aligned Left

Text Aligned Right

Text Aligned Center

Font sizes,  styles, and align modes can be changed prior to typing the text.
Make the desired choices from the Text menu at the top of the screen before
typing the titles, paragraphs, or captions in the designs.

NOTE: Placing in excess of forty text boxes on the screen may result in
distortion of  subsequently placed text boxes on the screen.
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